Question

Why am I getting this error while trying to run a bot? UNKNOWN: User: (username) is already running a bot on device: If the problem persists, please contact your system administrator.

  • 22 September 2022
  • 24 replies
  • 158 views

Screenshot 2022-09-22 How to fix this issue?


24 replies

is there any bot is running already on the device ?

if its shows any activity in in progress , cancel it or move it history and run it again

most likely someone has logged in to the Control Room with "X" user from device "Y" and ran a bot.

 

The bot which has been run with "X" user is still running but while it was running on device "Y", you logged in to the Control Room with user "X" from device "T". As soon as you had signed in with user "X" , other session of user "X" in device "Y" dropped. However, your sign in does not effect the bot(stop) running in Device "Y" with the touch of user "X".

 

To me for that reason, you need to first stop that bot running in device "Y" and then retry running the bot through the device you faced with such an error.

 

I hope this explanation will help you.

Any resolution to this issue? I am now having this same problem.

 

Thank you!

Same is happening here. The control room was unavailable yesterday around 3PM EST and since it appears that a bot is still running. Even if I shut down the AA bot service, the control room still shows it as connected. I believe this is a host side issue that cannot be solved from the user side. Trying to delete the host gives an error that a bot deployment is in process. Looks like we'll just need to wait it out until AA fixes it.

I have the same issue on two different accounts on two different machines. As soon as I try to start a bot I get the same message.

Hey @Sandeep K​  @Robert McDermott​  @Ross Veitch​  @Fred Amiri​  please open the "Task Manager" and end all the "Automation.BotAgent*" task that are running under the "Background Process" tab.

Hi

This makes no difference. There must be an issue at the backend.

I have gone so far as to completely uninstall the bot agent and then reboot. Exactly the same problem still remains. In task manager I can no longer even see the AA bot agent. But when I log into AA it shows me as still being connected.

When I try to disconnect the device, it refuses to do so because it tells me that there is a bot running.

imageEnd all these "Automation.ObjectAccessibility..." task using Task Manager. This will solve the issue.

Apologies - should have posted in the reply but dumped my reply in the main thread.

Thanks for the help. I don't seem to have those running. But I'm still getting the same error.

 

image

Same here, I don't have those processes running. Still dead in the water.....

Same boat as my fellow AA 360 CE users..

Thanks, @RK 2021, but seems that after completely removing the AA instance from my machine, and deleting registry files, removing the bot agent using CMD to completely delete it, does not help, there is something that is going on on the host side, AA 360 CE Edition. After a few days, it's still giving this error for detecting a ghost deployment and throwing false errors without allowing the user to DELETE the device and reinstall.

Hi, I have the same problem, has anyone managed to fix this problem?

Hi @all

I am also facing the same issue from the day before yesterday, I try to restart the bot agent service in task manager and also uninstalled and install the bot agent but still the issue is not resolved.

Hello @all

Does anyone find any solution for this issue?

My problem came right yesterday at abooy12h00 GMT. I disconnected the device and reconnected it and it worked. Up until then I had been unable to even disconnect the device.

Have you tried disconnecting and reconnecting the device since yesterday?

Hi everyone,

Im getting the same error today.

 

In incognito, I tried to run a bot. Then it stuck at deploying. So I closed the browser.

After reopen the browser and login to AA. I am unable to run any bot now.

Please let us delete in progress activity.

Yes, today morning I am trying to disconnect the device but the device is not disconnected also I uninstalled the bot agent but then also the device is not disconnected.

Which edition are you on. I was on Community 2

I am also using the same version Community 2 and bot agent version 21.221

I'm on bot agent 21.222 on both machines / accounts. Try updating the bot agent but when I had the problem even uninstalling the agent and running without an agent installed made no difference. Not even a different error message. But maybe it will make a difference now after yesterday's fix, whatever was done. Good luck.

Hello,

 

I had the same exact error but it maybe possible the root cause for this same error could be different to all of us facing this error.

 

I had to restart bot agent service in services.msc and post that it works fine. It is also interesting to note that, it does make the error to go away but comes back again if the bot is stopped midway. So, I have been restarting bot agent service every time i get the error which is annoying but at least I am not completely blocked.

I tried this but it does not work. Did you find any solutions for this @Ross Veitch​?

Reply