Question

Infinite pending execution problem. What can I do?

  • 24 September 2022
  • 47 replies
  • 482 views


Show first post

47 replies

Badge +4

Hello Micah,

 

I can confirm that the issue is not yet resolved as the new questions in this forum are also around the same issue.

 

I think the issue has been fixed for:

https://community.cloud.automationanywhere.digital

As the users on this CE reported that the issue is resolved.

 

But the issue is still not resolved for:

https://community2.cloud-2.automationanywhere.digital

As I do not see the users reported this URL posted that the issue is resolved.

 

Appreciate very much your kind support in this regard.

 

Fouad Sabry

it seems to works right now. I was able to delete device and connect again but there is still pending execution in activities which looks like just sits there and do nothing, also im able to run other bots so its fine by me. Thanks alot

BIG THANKS to Micah Smith for assisting with this little bug, Yes it is currently working, as usual, I was able to remove the old device and re-install a fresh bot agent. Currently, the bot agent is running and executing bot processes as normal.

 

Thanks again.

 

Please follow up with your community URL pasted for assistance,

Other environments may be affected

Hello Micah,

https://community2.cloud-2.automationanywhere.digital/#/home/p>

Hello @MICAH SMITH​ 

Still, I am not able to run the bot because the pending execution bot is not removed from the In progress tab also I am not able to delete the local device, Please help me to resolve the issue.

Thank you...

Hi Jitendriya

 

The link below explains, the process to delete the pending execution. Need to use the Postman to get this done.

 

follow the process mentioned in the link. Let me know if you were able to get it solved.

 

https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environments/

 

Hello @Jaizal Pilathottathil​ 

I am already following the above steps, I don't have admin user privilege and am using community edition, trying with my URL and getting the below response.

image

Team,

 

I have done the same on community edition and was able to delete the process

The error shows that you are logged into the community edition on the browese...log out of the browser...and then run the postman ​

Badge +4

I think this procedure is applicable for the enterprise edition and will not work for the community edition as the users are not administrators.

 

Let us hope that the support and engineering team have plans to fix this issue this weekend.

 

This issue is prolonged since last Saturday (7 days).

I logout from the community edition and running the postman but still the same response I am getting.

Hi Jitendriya,

 

I think the best option is to get the support # from the CR and call AA, as this was the same issue for folks with Community2 edition after Engineering was notified it took a couple of hours but they resolved the issue, they basically deleted the "Connected" device.

 

I suggest you call them, if they say go to the Community Forum and post your question. Let them know that for a week, there was a major bug it is fixed for most but not for me. I am sure they will assist. I know how annoying it is and no articles currently help, as the API technique is only good as ADMIN, I was able to get my device ID and run that, but it just errors out (No User is an admin on CE)

 

Hope you get back on it.

 

Support

1-888-484-3535

408-834-7676

 

Hi all,

Same Issue I face now, previously the issue is resolved by updating the bot agent itself.

what can I do now to resolve the issue?

 

Thank you...

Userlevel 6
Badge +9

Hi Jitendriya,

Can you please share the error screenshot, bot execution id, and bot agent logs with us?

 

Thanks,

Aarjav Sheth

Software Engineer at Automation Anywhere Inc.

Hello @Aarjav Sheth​ 

The actual problem is that I am not able to delete the local device

imageStill yesterday one pause bot is there in the in-progress tab but now there is no bot in the in-progress tab

imagePlease check the attached file.

Thank you...

 

 

Hi @Aarjav Sheth​ 

For me the issue is not resolved, I don't have any active bot deployment in the in-progress tab but still, the connected device is not deleted.

Please find the screenshot below

In-progress tabYou can see there is not an active bot in the In-progress tab.

Device pageI try to delete the device but the device is not deleted.

Please help me how can I resolve the Issue

 

Thank you...

 

Badge +1

The same problem with no solution in community2

 

 

Userlevel 7
Badge +13

The same problem with no solution in community2

 

 

 

 

Please check the below thread and try to reset your runner device through API call using Postman. Let me know the result.

 

Bots Struck under "In-Progress" | Community (automationanywhere.com)

 

Badge +1

I followed the steps, but the final result was:

 

 

Badge +2

@Micah.Smith 

Hello Micah, Hope this finds you well

Did we get any solutions for this case? as I’m facing it in my on-prem control room. Thanks in advance

 

Userlevel 5
Badge +9

Best to contact Automation Anywhere support on this @Mahmoud Abdelmaged  so they can investigate your specific situation

Badge +2

Hi @Micah.Smith , thanks for your reply. 

Unfortunately, my account is not authorized to raise a tech support ticket and I was emailing the partner enablement team by this also.

Appreciate your support on this issue and topic if possible. Thanks a lot in advance. 

Reply