Question

Infinite pending execution problem. What can I do?

  • 24 September 2022
  • 41 replies
  • 66 views

Hello, i have trouble with infinite pending execution. I already tried to restart the service via services.msc without the result. Also im unable to delete device. I also tried to reinstall bot agent and clearing everything it had in Automation Anywhere folder. but it casuses another problem with additional device to be registered. Has anyone else got this problem and solved it?

 

image.pngimageimageIm looking forward for any of the solution to solve this problem because im unable to do any other stuff on automation.


41 replies

also I can mention that i have the update status on my device but Im unable to update it.

imageimageimageand there comes the previous problem that im unable to connect the device because there is already registered device, and im unable to delete it. Its like infinite error loop for me.

i am also experiencing a similar problem.

I'm in the same situation. Since last friday.

I hope a quick solution

I forgot to mention that i'am using community edition (via my university) and looks like i have no access privileges to check this page - You are not authorized to access this page, kindly reach out to your Account Executive / Company Administrator to enable access.

 

So if you could describe me what to do i would be very grateful.

Userlevel 3
Badge +6

Try this: https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environments/p>

I tried this for all devices and I'm getting the following response.

 

{

  "message": "Can reset only device registered by you"

}

 

There is only one user and the authentication is working correctly.

 

I tried using the specific device name with all different combinations of square brackets, carets and quotes

 

{

 "deviceIds": {  

 "ids": <MACP17KQ>

 }

}

 

but I only get this response:

 

{

  "code": "json.deserialization.exception",

  "details": null,

  "message": "Invalid request parameters"

}

I have also tried this and received the same response as above - I believe it is looking for a digit #s for ID but in place, we are providing what we have is our device name, mine also is my PC name. Are we able to login as Admins or run the API's call through admin mode somehow?

Thank you!

Userlevel 3
Badge +6

Working with support/engineering for a more global fix...stay tuned

I'm in the same problem with the community edition. My user is only a Bot Creator and i don't have admin permission.

Since last friday i've a bot stuck "in progress"

image

Hello Micah,

 

The URL is:

 

https://community2.cloud-2.automationanywhere.digital//p>

 

Thanks a lot for your kind support.

 

Regards,

Fouad Sabry

Thanks, Micah,

 

Just for the sake of the other users,

 

You are able to retrieve your device ID by making an API call, however, to save you time, I have done this and the output still results in an error. See the screenshot below.

 

Thank you!

 

API call to Reset by Device ID 

 

 

 

https://community2.cloud-2.automationanywhere.digital/#/login/p>

 

https://community2.cloud-2.automationanywhere.digital/#/login/p>

https://community2.cloud-2.automationanywhere.digital/#/login?here is mine, this is exactly the url provided from Automation when i registered my account.

Userlevel 3
Badge +6

Hey - for anyone experiencing this issue, can you post the URL of the Community Edition control room you're using? We have a couple CE environments, so trying to isolate if its limited to a certain env or not

Thanks a lot Micah ....

 

Just to save the efforts, I have done the following steps and did not resolve the issue:

 

URL:

https://community2.cloud-2.automationanywhere.digital//p>

 

I have run a bot and it stayed very long time without execution so I just clicked on Cancel.

Then I tried to run it once again, and it gives me the following message:

//

UNKNOWN: User: (<user_name>) is already run

ning a bot on device: (<device_name>)

//

 

I tried also to delete the device but it gives me the following message:

//

Cannot delete device, as it is part of an active bot deployment

//

 

So, I have tried the following action without any success in resolving the issue:

 

1 - Restart the "Automation Anywhere Bot Agent" service.

2 - Stop and then Start "Automation Anywhere Bot Agent" service.

3 - Uninstall and install the agent.

4 - Uninstall and clean the AA folders in the profile and install with admin the agent.

5 - Restart the computer

6 - Leaving the computer shut down (clean shut down with no sleep and no hibernation) for 1 night.

7 - Installing an older version of Automation Anywhere Bot Agent.

 

These steps did not resolve the issue.

 

Thanks a lot in advance for all your kind support and cooperation.

 

Kind Regards,

Fouad Sabry

Userlevel 3
Badge +6

OK give it a try now...same for anyone else in this thread - try it again. I was told the support team was able to establish disconnections for everyone at 12PM PST. Let me know if you're still having issues

Thanks Micah but i keep having the same problem

Userlevel 3
Badge +6

Whats your control room URL @Leandro Castello​ ?

Sorry, I finally tried running the bot and it worked. The bot that was causing problems continues to appear in "pending execution". But the CR works perfectly right now. Except for the detail that continues to appear in "in progress" Thanks you so much !!

 

Thanks, I am now able to add and remove devices so that's good. I still see the In Pending execution but it doesn't seem to be affecting anything anymore.

 

https://community.cloud.automationanywhere.digital/#/p>

Hi Team,

 

Was able to get the issue fixed with support Engineer... The below is the link for the solution

https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environments/

Unfortunately, I cancelled the bot and can not de-register the device, and now I can not run the bot again for the same previous issue " user is already running a bot on device".

 

I think the fix was temporarily and tactical, as the "pending execution" is still in the In Progress.

 

I really need your kind support to fix this issue forever.

 

Kind Regards,

Fouad Sabry

Can't access the solution, can you post it here please? Thanks!

Hello Micah,

 

I can say that there is a progress in a sense that the bot did not give the previous error message, but it is still in the phase of "Notifying device" forever.

 

last time, I have cancelled it and it gives me the same global issue.

 

I will try to de register the device and register it once again.

 

Thanks a lot Micah for your kind support.

 

Kind Regards,

Fouad Sabry

Reply