Solution Pattern - Run Remote on Demand

  • 2 October 2023
  • 0 replies

Userlevel 1
Badge +1

This pattern - one of the most simple - involves logging in to the Control Room to execute the automation when required. The automation will execute on one or more unattended runners/devices.

Use this pattern any time you need a process executed ad-hoc - ie. when/as required. This pattern is frequently used for automations supporting project activities including data migration / transformation, often required to upgrade/implement business systems.


EXPERT TIP:  If human intervention is needed to resolve process exceptions identified during execution, consider use of the “Unattended + CoPilot” pattern.




Development Framework: Any Automation360 Development Framework can be used.

Solution Design (SDD): A sample SDD is attached.  

Administration: You’ll need a role defined that has access required to allow scheduling of an automation.  One or more ‘custom roles’ could be created for this purpose - see samples at the following link.

How to Use: Follow these steps from the Automation Anywhere Doc Portal to execute an automation. 


Troubleshooting Execution:



I don’t see AUTOMATION in the menu at all.

The user logging in to the Control Room to run the Bot needs a Role with ‘Run Bot’ access

I don’t see the folder containing the automation I want to execute

The user logging in to the Control Room to execute the automation needs a role with access to the folders containing Automations you need to be able to run/schedule.

I don’t have any options in the “Available bot runner” list.

The user logging in to the Control Room to execute the Automation needs a role that includes “Run As Users” representing the Bot Runners on which the Automations will execute.

Error “Either your username or your password is incorrect “

For the user representing the Bot Runner, the username/password in the “Device Login Credentials” section must be accurate.

RDP errors are generating when deploying the automation .

If using Windows Server, ensure the Ctrl-Alt-Delete is ENABLED in local security policy settings.

0 replies

Be the first to reply!