@VanithaR
Title
Automation 360 WLM : WorkItems stuck in Ready to Run Status
Summary
Applicable for Automation 360 (formerly Automation Anywhere Enterprise A2019) v.18 & v.19
WLM queue unable to deploy workitems in the device associated with device pool, making the items stuck in Ready to Run status.
Cause
Right after an upgrade from Automation 360 v.17 to Automation 360 v.18/Automation 360 v.19; we observed that cache was going into this state where currentAutomationIndex is set to 0 and the pool's scheme would be AUTOMATION_SCHEME_UNKNOWN for Device pool status.
We have a workaround in this case and that's to just drop the device pool and recreate it as it'll reset the cache.
Resolution/Workaround
The permanent fix will be available in Automation 360 v.20 version of Control room.
@rbkadiyam @VanithaR has this been fixed? I am facing this same issue in v27
Hi @Andoni Yes. We manually ran the Bot in the VM in attended mode (which eventually failed) but somehow this made the queue to pick up the VM correctly when we triggered the queue again.
This is so weird that it resolved the issue, but unfortunately we were unable to find the root cause because there was no errors even in the Control Room Web CR logs. Not sure if this will resolve your issue, but just give a try and let me know if it works
Thanks
Vanitha R
Hi @Andoni Yes. We manually ran the Bot in the VM in attended mode (which eventually failed) but somehow this made the queue to pick up the VM correctly when we triggered the queue again.
This is so weird that it resolved the issue, but unfortunately we were unable to find the root cause because there was no errors even in the Control Room Web CR logs. Not sure if this will resolve your issue, but just give a try and let me know if it works
Thanks
Vanitha R
Thanks a lot for your response! I just deleted the device pool associated with the “Run bot with queue”, re-created it and eventually it worked (I am not 100% sure that this has been the solution of it...)
So weird….
If the error is persistent with the bot preprocessing please refer to the below article. We have experienced errors occurring in the workload queues such as workitems in a queue not executing due to this bot preprocessing error.
https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/error-reference/preprocessing-error-messages.html
preprocessing of child bots does not occur in sequence because these bots are referred in the parent bot and are sometimes in complex nested workflows and due to this error will not be reflected in the audit log as well