I need to put a series of keystrokes in Excel: 1. Y3, 2. Y4, 3. T., 4. Enter However, after I put y3, it does somehow not hold the “ALT”, so that it puts “Y4 etc.” in the activated cell instead of using it as a keystroke.

I tried several options for the command, none of those are working (I also tried to vary the delay time.

  • [ALT DOWN][ALT UP]y3y4t
  • [ALT DOWN]y3y4t[ALT UP]
  • [ALT DOWN]y3[ALT UP] & new line [ALT DOWN]y4[ALT UP]

12 replies

Hi You can put keystrokes into variables and use the variable for the key simulation.

  • Ex: $Variable$ = [ALT DOWN][ALT UP]y3y4t
  • use the $Variable$ in the keystrokes action


Thanks a lot for the quick answer!! I tried it, but unfortunately it is not working. it is after typing Y§ losing the ALT and thus writes y4... in the activated cellError result:

Variable definitionCommand including variable

If the keystrokes sequence includes in ALT, try using

  • [ALT DOWN]y3y4t[ALT UP]

this should work


I tried that option (see above), but it does not work unfortunately

I see.....

then you can try customizing the Shortcut keys in excel

  • fix a shortcut key to access the IBM planning Analytics that can be used globally (Ex: ALT DOWN]MIALT UP] or ALT DOWN[B[ALT UP] this will be one solution for this kind of scenarios.
  • Another Solution is Create a Macro and Run ( Most Reliable when it comes to Excel)


( In general Keystroke Actions and Action performed in Excel is a bit delay process when using AAE )>

Thanks again for your support.

Option 1: In my Excel I can somehow not customize the shortcuts, I miss totally the field "customize" (see below)

Option 2: I created a marco which works perfectly fine when executed in excel, however executed in AA, the original error comes up again (that the series of keystrokes is not executed, only the first one and the rest is written in the activated cell)


... I really have no clue how to solve this issue. 2022-05-06_13h52_42 



ohh that seems fishy

are you using AA Commands to run the Script (VBScript Command ) ?

If so dont use the AA Command, use keystrokes to run the macro.

ALT + F8-> to open macro window, using the ALT to select the macros to run.

2022-05-15_21h14_38Hi Yokogawa, thanks again and sorry for my late reply. I just tried your solution and the start of the macro with ALT + F8 works, however, AA still does not get it, still writing the "y6t" of "y4y6t" in the excel idea why it does not work with all the tries.


The crazy thing is, when i start the macro by hand instead of by AA, it works perfectly

Is there a solution to this issue? We have the exact same problem when we try to simulate [Alt Down] CX [Alt up]. We tried all different permutations, including the C and X pressed after the [Alt Up], and we still have the last character (X) printed out on the cell. This seems to be a serious limitation of the platform.

@Clara Rösen​ Hi, I was wondering if you were able to find a solution to this? I have spent many hours on the exact same thing, trying different ways of carrying out the Alt related action but to no success.


@Ninad Kanade​ I was wondering if you had any idea of the above issue. I have the same exact problem and have opened a ticket too for this.

Hi Fotis, finally I found a solution thanks to a colleague. I used the "Record" function in combination with first maximizing the window of the file and then object cloning, carrying out all the single steps one by one. It works perfectly!


Hope that helps?! Otherwise please feel free to reach out, I can show you2022-05-23_07h55_56

See answer in other post with solution =)