Error performing single capture

  • 22 February 2022
  • 12 replies

while giving the constrains to capture block it is showing error with extension.


"your chrome plug in is either not installed or disabled. for trouble shooting help, visit the automation anywhere documentation and search for 'chrome plugin' "

if the problem persists, please contact your system administrator


12 replies

Userlevel 5
Badge +12

Hi @Uday kiran Lalam​ ,


Can you check if your screen resolution is 1366*768 & Browser Zoom is set to 100%?

no i am not using Incognito tab

it is showing same error


Badge +3

@Uday kiran Lalam​  I too faced the same issue at initial stage.U can get it resolved by uninstall bot agent and remove registered device in device section and re connect with ur device again.

@ChanduMohammad S​  i tried with this "screen resolution is 1366*768 & Browser Zoom is set to 100%" but still that error hasen't resolved


Userlevel 5
Badge +12

Hi @Uday kiran Lalam​ ,


Can you restart the Bot Agent >> Refresh IT bricks Web Page and try again?

Userlevel 5
Badge +12

Hi @Uday kiran Lalam​ ,


Checkout below KB for resolution,>

after i change that resolution i opened that page

imagethat page itself showing error

Userlevel 4
Badge +7

Hi @Uday kiran Lalam​ ,


Could you verify whether the Chrome Extension is Enabled?

If you are running this in Incognito, ensure that the Extension is enabled for Incognito as well.


Kind Regards,

Ashwin A.K


Userlevel 4
Badge +7

Hi @Uday kiran Lalam​ ,


Could you try reinstalling the Chrome Extension and try once more?


Kind Regards,

Ashwin A.K

@Uday kiran Lalam​, Please find below KB article content.


If you are on Automation 360 v.20, the below error is observed in the Bot Agent logs. The UI error mentioned is listed at the start and the stack trace indicates the ComException.


  yyyy-Month-dd Day 15:18:52.478 ERROR - BotRunner-ad59a0b8-cb0b-4823-bdee-019856599f5c_f2957fbbc5259a36 - {deploymentId=ad59a0b8-cb0b-4823-bdee-019856599f5c_f2957fbbc5259a36, traceId=f2957fbbc5259a36} - handleThrowable( - bot status 'FAILED' updated com.automationanywhere.botcommand.exception.BotCommandException: Your Chrome plug-in is either not installed or disabled. For trouble-shooting help, visit the Automation Anywhere Documentation and search for 'Chrome plug-in'.


If the problem persists, please contact your system administrator.

at com.automationanywhere.recorder.service.impl.PlayBackServiceImpl.playBackRecorderCommand( ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]





at Source) [?:?]

Caused by: COM object method returns error code: 0x800706BE; The remote procedure call failed.




Cause 1:

One of the possible causes for this error is that, 11.x Client application and the corresponding Chrome Plugin (12.0.0) were installed earlier on the same machine. Despite uninstalling the AAE 11.x Client application, registry settings for the Chrome plugin are retained.


Cause 2:

If you are on the Automation 360 v.20 release, the error message is misleading and indicates an issue with the Chrome Plug-in which may not help resolution of this error.


This is an intermittent problem encountered with the Internet Explorer (IE) where sometimes we receive a ComException from the browser Internet Explorer (IE). This error is observed when the IE browser crashes or generates an error to the Automation 360 API call during bot execution. This error is generally received from the IE browser end when the webpage/UI on which the action is being performed has not yet fully rendered the objects or loaded the webpage and the action is executed.


With Automation 360 v.19 or prior releases, the user will receive the error message that "Unable to find requested object 'Search Criteria' did not match."


Cause 3:

Default package content is missing from the GlobalCache folder; this behaviour has been addressed in A360 v.22 and above.


Cause 4:

Below files are missing in the folder of the Recorder package version of GlobalCache though the Automation.Bot.BrowserAgent.exe seems to be running in Task Manager: 

i. AAChromeAgentManifest.json

ii. Automation.Bot.BrowserAgent.exe


Cause 5:

Recorder default package is not selected.


Cause 6:

The 'Automation.Bot.BrowserAgent.exe' is not running in the TaskManager-> Details tab.


The '' folder exists in the registry path: "Computer\HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts"





Solution 1:


Perform the following steps to resolve the issue:

  1. Remove the NativeMessagingHosts setting for the 11.x Chrome plugin registry setting. Computer\HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts\ (Solution mentioned under Point#5 of the below article)
  2. Restart the Chrome browser and try recording again.

Note: Verify if "" has been created in the registry under (for versions A2019.15 and above) Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Google\Chrome\NativeMessagingHosts

  1. Make sure the user has access to the C:\ProgramFiles\Automation Anywhere path where the  AAChromeManifest.json file is located. 

Default Path:- C:\Program Files\Automation Anywhere\Bot Agent\AABrowserAgent\AAChromeAgentManifest.json

  1. If the above steps do not help resolve the issue, please try the following:
    1. Stop the Automation Anywhere Bot agent service.
    2. Navigate to C:\ProgramData\AutomationAnywhere\GlobalCache.
    3. Delete the content of the Global cache folder.
    4. Start the Automation Anywhere Bot agent service.
    5. Try re-running the Bot and see if that helps.


Solution 2:

The bot creator/user will need to add additional delays in the bot to allow the webpage/UI Objects to be first fully loaded before executing the recorder options.


Solution 3:

These steps are only applicable to A360 v.21 and below since v.22 has addressed the package missing from the GlobalCache issue. However,  a one-time cleanup can be required to clear out any previous files needing cleanup. This cleanup can also be required if upgrading from A360.20 or A360.21 directly to A360.23 or A360.21 directly to A360.24. The steps to be followed are as follows: 


If Automation.Bot.BrowserAgent is running and still, the same error is being received then change the recorder package. If the latest recorder package is not present in the GlobalCache folder then perform the below steps

  1. Stop the Bot agent service.
  2. Delete the GlobalCache folder. The folder would be present in  C:\ProgramData\AutomationAnywhere
  3. Start the Bot agent service.
  4. Now try to use the latest package. The folder of the latest package should be created in C:\ProgramData\AutomationAnywhere\GlobalCache\embedded-resources.
  5. If it is not created, then uninstall the bot agent and delete the GlobalCache folder.
  6. Install and register the device.
  7. Now run the bot with the latest recorder package.

Solution 4: 

Applicable for the Bot Agent versions greater than 18.19

1. On the Bot Agent machine, navigate to the location C:\ProgramData\AutomationAnywhere\GlobalCache\embedded-resources.

2. Locate the Package for the Recorder command and take the backup of the folder. ( The name of the package would start with the version of the Recorder Package being used in the bot).

For instance, if Recorder package used is of version 2.2.0-20210507-195346, then the folder name will be in the form of 2.2.0-20210507-195346-d49ca70a-a160-4b95-b53a-d242654184c0.

Note: The Hexadecimal part in the folder name will be dynamic.

3. Open the Installation path of Bot Agent, C:\Program Files\Automation Anywhere\Bot Agent\AABrowserAgent.

4. Copy the below files:

   i. AAChromeAgentManifest.json

   ii. Automation.Bot.BrowserAgent.exe

5. Paste it under the folder located in Step 2. 

6. Restart the Bot Agent service.

7. Capture the object using the Recorder. 


It should capture the objects now. 


After following the above-mentioned steps if the issue persists then perform the below steps:

  1. Delete the ComSpec environment variable.
  2. Restart the machine
  3. Add the ComSpec environment variable.


Solution 5:

Make sure that the Recorder is selected as the Default version on the Package page.


Solution 6:

Remove the entry '' in the registry path: "Computer\HKEY_CURRENT_USER\Software\Google\Chrome\NativeMessagingHosts".


After removing the registry entry, 'Automation.Bot.BrowserAgent.exe' should be running in the Task Manager-> Details tab.

Note: After making registry changes, restart the machine.