Solved

Bot stuck connecting to device

  • 4 October 2023
  • 5 replies
  • 185 views

Badge +1

Hello community.

 

I have an issue when running my bots, this happen to scheduled bots and to bots I run from the control room.

I’ve tried the next solutions.

  • Uninstall the bot agent and reinstall it again.
  • Delete the global cache.
  • Restart the server.
  • The server has enough disk space.
  • I’ve check if the firewall or antivirus is blocking anything but no. 

 

icon

Best answer by ravi.pothana 4 October 2023, 21:00

View original

5 replies

Userlevel 5
Badge +9

Hi @hector.olivos 

You have the following message in your logfile:

 

message: "Unable to create the folder because access to the path \'\\\\nasbccmx\\Corp_Admi_Y_Finanzas\\06_COMPROBANTES PAGOS GRUPO\\Comprobantes Pagos Grupo\\\' is denied." 

 

In addition, the following error message:

 

2023-Oct-04 Wed 08:30:49.356 ERROR [pool-24-thread-2] - com.automationanywhere.nodemanager.service.impl.GlobalCacheServiceImpl - {} - lambda$downloadFile$79(GlobalCacheServiceImpl.java:1412) - Unexpected error downloading and saving file http://lerrpactrlpsrv.bocar.com:81/v2/repository/files/packaging/60ac32d8-ce46-44a9-8b02-c4eb5f059e48/35784.jar java.net.SocketTimeoutException: Read timed out

 

Seems you have any networking restriction  or missing permissions.

 

Regards.

Userlevel 3
Badge +8

Hi @hector.olivos,

Lets try few things:

  • Make sure proxy configuration is setup to allow this download URL from this device - http://lerrpactrlpsrv.bocar.com:81/v2/repository/files/packaging/
  • Ensure user has following permissions:
    • For bot runner 
      • -run my bots
      • -view packages
    • For bot creator:
      • view my bots (all child permissions)
      • view packages / manage packages
  • ​​​​​The bot agent service user should have read\execute\modify\full control permissions to the GlobalCache folder located at C:/ProgramData/AutomationAnywhere/GlobalCache.
Badge +1

how can i check for proxy to allow the download of the URL? 

Userlevel 3
Badge +8

Hi @hector.olivos,

For this you can leverage Bot Agent diagnostic utility, The utility helps to diagnose issues either by providing solutions or suggestions to help resolve the issues.
https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/bot-agent/bot-agent-diagnostic-utility.html

Badge +1

I’ve tried cleaning the server and making a clean install of everything but i keep getting the error: "Unable to download the bot or the dependencies to the device","details":"This may be due to multiple reasons. To continue, please\n\n1. Make sure that there are no errors with the dependencies\n2. Make sure there is enough disk space on the device for the bot and all of the dependencies\n3. Make sure proxy configuration is setup to allow this download URL from this device.\nThen, try to run the bot again.\n\n\nIf you continue to see this message, please contact your system administrator.","correctiveAction":"","code":"download.error"}

Reply