Question

Hello All, I am new member and facing issue while running bot. I am the only user on machine and having admin right . After Run, it showing error " User Not logged into the machine" It will be great help if you guide me on this issue

  • 16 April 2021
  • 9 replies
  • 396 views


9 replies

Check your states of connection with Control Room and local machine, or credentials on the top-right banner.

It will be helpful if you reinstall your A2019 Bot Agent program in your local computer

Go to the computer Icon top right, next to the ? icon and the world icon. It should have a green tick.( if not there is another problem because the device is not connected with control room.)

 

Then tick the computer click update credentaials and put in your windows credentials you use to login to that machine. If you are part of a domain include that e.g. domain\username for the user name.

 

The reason is that Bots need authentication on the bot runner to run and also to be able to unlock the bot runner if the screen is locked or it is logged out.

Thanks ! I will try this

Thanks Simon!

I have checked as per your suggestion and confirmed that it is showing green tick and credentials are same. But still am getting same errors message.

my user name is different than device name ; and think that not an issue.

For your reference; attaching screen capture of device status

 

Apologize for taking your valuable time

 

 

That all looks good. You have the green tick. The user not logged in message is definately all about the windows credentials every time I have had this with users connecting to enterprise for the first time it is usually that. So the only thing I can think is how you enter those. The common mistake is that people (including myself) put in the AA login credentials but it is critical you put in your Windows username and password. You must also include the domain. Can you double check that in "update credentials" you have entered the correct windows username and password ? Sorry to ask, as I am sure you have done it but it is worth checking. If that doesn't work I don't know what the answer is. If you are NOT in a domain then it should just be the username but it is worth trying .\username just in case. if you are make sure you have put that in too.

 

If none of that works then it is something else and I have no clue, but I doubt it is something else as the error message is very clear.

Thanks Simon! Today I checked about Domain name and problem is resolved.

Thanks for your time and help.

Awesome. Glad it worked.

 

It may be worth mentioning that sometimes you have to also experiment with that even not in a domain e.g. hostname\username and sometimes even .\username has worked when not in a domain so basically I do the following:

 

  1. If in a domain DOMAIN\UserName
  2. If not Username
  3. If that doesn't work .\username
  4. If that doesn't work hostname\username

 

That will usually crack it 😀

Badge +1

Now i’m using Window Hello as Device Login Credentials and Not using password anymore. Now this PIN is not accepting while setting device credentials. Earlier when i was using password, i could able to run the bots. But after updating to passwordless feature(Only Windows Hello PIN), I’m getting device credentials issue. Kindly guide on this.

Reply