Dowload folder incognito mode chrome

  • 24 February 2023
  • 3 replies

Badge +6


Until couple of days ago when the bot downloaded a file in the incognito mode the file was stored by default in the Download folder. 

There was a Chrome update and now when it downloads the file 

  1.  A new tab (Untitled) opens 
  2. The Save as window pops up and unfortunately the default folder is desktop instead of Downloads. 

How can I set the default folder to be “Downloads” ? (In the Chrome preferences it is set up correctly





Best answer by cheesus23 2 August 2023, 16:27

View original

3 replies

Userlevel 7
Badge +13

Hi @avibabo ,


Normally the Save As window will popup if you enable the “Ask where to save each file before downloading” option. But it seems strange that the popup is coming even though the option is not active.  Try resetting the Chrome once and check.


Else, you can do a workaround here.

Assign the Downloads folder path to a variable and use that along with the file name separated by ‘\’. Use Simulates Keystroke action on this Save As window and put this Variables there.

Userlevel 5
Badge +14


  1. On your computer, open Chrome.
  2. Go to the site where you want to download the file.
  3. Save the file:
    • Most files: Click the download link. Or, right-click on the file and choose Save as.
    • Images: Right-click on the image and choose Save Image As.
    • Videos: Point to the video. Click Download . If you can't do this action, the video's owner or hosting site has prevented downloads.
    • PDFs: Right-click on the file and choose Save Link As.
    • Webpages: At the top right, click More More and then More Tools and then Save Page As
  4. If asked, choose where you want to save the file, then click Save.
    • Executable files (.exe, .dll, .bat): If you trust the file, click Save. If you're not sure about the contents of the download, click Discard.
  5. When the download finishes, you can find it at the bottom of your Chrome window. To open it, click the filename.

To find a file on your computer, next to the filename, click the Down arrow Down arrow and then Show in folder or More  and then Show in Finder.




not sure if you ever found a fix for this, but we have just had the same issue

this is not a BOT but a chrome issue (not found the root cause yet)

but there is a way to fix this



in chrome go to chrome://flags/#incognito-downloads-warning

in the search at the top, search for Enable download bubble and set this as disabled

click the relaunch button


test again, this should direct download the file into the download bar across the bottom of chrome