Device Credential is showing ERROR


My device credential is showing error while running the bot. 

I tried to remove device. Added local device again, updated the bot agent once again still device credential is showing error. Please help!

What should I write in device credentials??

I checked on AA Support and there they have mentioned we need to write “domain\username”

I dont have a domain, I have a personal computer.

I also tried removing ”AzureAD\” still it is giving an error.

I am attaching the screenshot



Best answer by Tamil Arasu10 15 June 2023, 12:17

View original

2 replies

Userlevel 6
Badge +15

Hi @Saquib 3873 ,

Please follow the below steps to get your device name:

>If you do not know your device name

  1. Open a command prompt
  2. Enter "whoami".

 Then, your device name will be output as result. 

  • If the user name is part of your company’s domain, use the format “domain \ username”.   (This is your device name, not your email address.)

>Next, please enter the password when you use to log in to your device (PC) usually

Badge +3

Hello @Saquib 3873 

- Get the device name from your system, Click on windows icon → Search for ‘About your PC’ → There you will find the name of your device.

Use this name for registering the device.

- When you uninstall the device or bot agent, Make sure you delete the files from: C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere also.