Question

Your Chrome Plug-in is either not installed or disabled on unattended bot runner?

  • 17 January 2022
  • 2 replies
  • 4 views

Hi,

 

We have 5 bot runner on VM in Production environment and one of the bot could not run task on google chrome and return an error as follow :

 

2022-Jan-17 Mon 16:35:27.586 ERROR - com.automationanywhere.botrunner.bot.Bot_Content {deploymentId=4f5876db-7bca-43ba-8b95-31503f2d682c_5fd9549db4eba908, traceId=5fd9549db4eba908} - play(Bot_Content.java:2547) - bot exception caught com.automationanywhere.botcommand.exception.BotCommandException: Your Chrome plug-in is either not installed or disabled. For trouble-shooting help, visit the Automation Anywhere Documentation and search for 'Chrome plug-in'. 

 

If the problem persists, please contact your system administrator.

at com.automationanywhere.recorder.service.impl.PlayBackServiceImpl.playBackRecorderCommand(PlayBackServiceImpl.java:88) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.recorder.adapter.primary.commands.CaptureCommand.execute(CaptureCommand.java:84) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.botrunner.bot.Bot_Content.executeNode41(Bot_Content.java:863) ~[?:?]

at com.automationanywhere.botrunner.bot.Bot_Content.play(Bot_Content.java:2460) ~[?:?]

at com.automationanywhere.botrunner.Main.play(Main.java:63) ~[?:?]

at com.automationanywhere.botengine.service.impl.BotLauncherImpl.runBot(BotLauncherImpl.java:22) ~[bot-launcher.jar:?]

at com.automationanywhere.botengine.service.impl.DispatcherImpl.lambda$start$8(DispatcherImpl.java:369) ~[bot-launcher.jar:?]

at com.automationanywhere.botengine.utils.ThreadUtil.lambda$withThreadContext$0(ThreadUtil.java:20) ~[bot-launcher.jar:?]

at java.util.concurrent.CompletableFuture$AsyncSupply.run(Unknown Source) [?:?]

at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]

at java.lang.Thread.run(Unknown Source) [?:?]

Caused by: java.lang.RuntimeException: Could not execute chrome request. Please make sure Chrome is running and your Chrome plug-in is installed and enabled.

at com.automationanywhere.webbrowser.adapter.ChromeBrowserAdapter.executeBrowserRequest(ChromeBrowserAdapter.java:242) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.webbrowser.adapter.ChromeBrowserAdapter.waitForBrowserDocument(ChromeBrowserAdapter.java:275) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.botcommand.sdk.browserapi.impl.ChromeBrowserWaitImpl.WaitforPageLoad(ChromeBrowserWaitImpl.java:52) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.botcommand.sdk.browserapi.impl.BrowserWaitService.WaitforPageLoad(BrowserWaitService.java:92) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

at com.automationanywhere.recorder.service.impl.PlayBackServiceImpl.playBackRecorderCommand(PlayBackServiceImpl.java:74) ~[bot-command-recorder-2.1.0-20210311-002508.jar:?]

... 11 more

 

We have tried to reinstall the extension on Chrome, restart the AA bot agent service but the bot agent still not run.

 

We have chrome version 90.0.4430.93 and the AA extensions's version is 1.1.0.3

 

Below are the log that includes the error line above along with our bot runner machine information


2 replies

Userlevel 5
Badge +12

Hi @Duy Nguyen Quốc​ ,

 

I'd recommend opening a support ticket with AA using below link and its Prod Env

 

https://apeople.automationanywhere.com/s/support/p>

Userlevel 6
Badge +9

Hi @Duy Nguyen Quốc​ ,

 

I request you to refer to the article : https://apeople.automationanywhere.com/s/article/Your-Chrome-Plugin-is-either-not-installed-or-disabled/p>

Reply