Question

Why Automation Anywhere control room reverse proxy service was paused? --- A360

  • 16 September 2022
  • 4 replies
  • 15 views

Hi,

 

We have configured AA A360 control room on-prem in VM.

 

Recently we have tried changing traefik.toml file from http to https.. its doesn't worked out so we revert it.

 

Now we observe that Automation Anywhere control room reverse proxy service was paused and not able to login to control room.

 

We have tried following link workarounds but nothing worked out.

https://apeople.automationanywhere.com/s/article/Automation-Anywhere-Control-Room-Reverse-Proxy-Service-keeps-getting-in-Paused-state/p>

 

In the above link they mentioned in validation2: Make sure that the ports defined for HTTP and HTTPs during installation of Control Room are listening under "traefik.exe" in Windows Resource Monitor. -- when we check in resource monitor traefik.exe app not exists, is this the reason? why we cannot see the traefik.exe in resource monitor?

 

Kindly revert it, if any one knows the solution for this..

 

Thanks,

Hemantha


4 replies

Userlevel 3
Badge +7

Hi @Hemantha Pindra​ ,

 

Please find the below detail,

 

  1. The first request from the Enterprise Client to the Control Room is authenticated by the Reverse Proxy server using the Client Certificate mechanism.
  2. The Reverse Proxy server returns the response with a cookie, which is used for all the subsequent requests.
  3. Each subsequent user login does not require additional authentication with a certificate. The same cookie is used when:
  • Trusted users change the Control Room authentication type.
    • Trusted users switch to another Control Room.

 

You have mentioned that above mentioned article is doesn't helps. so I recommend you please reach out automation anywhere support team and they will help you to resolve this issue.

 

 

Thanks!

 

Thanks we already raised AA ticket for this but for time being I raised a question so that I can get any answer. Finally AA team resolved it.

Answer: May be it helps for any one.

 

It was port issue AA port is linked up with other application so, they have changed the ports for Automation anywhere and added into firewall inbound and outbound, later restarted all services of AA then the control room reverse proxy started running.

Thanks to @Jayachandran Rajasekaran​ for resolving this issue.

Userlevel 3
Badge +7

Thanks for sharing here.

Reply