Solved

User not logged in

  • 29 December 2022
  • 6 replies
  • 196 views

Badge +1

Hi,

 

I am getting below error message while deploying Bot to the Runner device. I know there is a KB article on fixing this issue when I googled the error but I am getting access denied error while accessing the same. If anybody can share that article content here would be much appreciated.

 

 

icon

Best answer by Padmakumar 29 December 2022, 09:54

View original

6 replies

Userlevel 7
Badge +12

Hi @Shilpa_sood ,

 

Please find the mentioned article link here. If you are still unable to access it, please let me know.

Badge +1

Hi @Padmakumar ,

 

Thanks for the reply but, sorry. I am still unable to access it.

 

Could you please share its content here?

Userlevel 7
Badge +12

Hi @Padmakumar ,

 

Thanks for the reply but, sorry. I am still unable to access it. Could you please share its content here?

 

Ok. I hope you have logged in. If not, please log-in and check.

 

Else, please find its content below.

 

Cause

The following are the probable causes:

  • When Pin is entered instead of password in the device credentials.
  • The registered device password is entered incorrectly while the bot runner account was created in the control room by the control room admin user.
  • When device is configured as "Single User" and is being used by multiple control room users i.e. bot creator and bot runner.
  • The Windows User credentials are entered incorrectly on the bot runner registered/installed device.
  • When deployment type is set incorrectly for the device.
  • The device is not mapped as the default device.
  • The Device is not part of the roles.

 

 

Resolution/Workaround

  1. Enter device password, do not use any other procedure for login to the device.
  2. Ensure the device password is correct by logging in to the control room admin account, navigating to Administration > Users, and editing the user account.
  3. Configure the device as "Multiple Users" as shown below screenshot.

     

  4. Update the Windows User credentials on the bot runner device credentials section as shown in the below screenshot.

     

Note: Device password here is the Windows login credentials

        5. Update the deployment setting correct.
Example: If running bot on local device the deployment type should be set as Regular and not RDP
 



6. Login with Admin user to your control room >Click on Administration ->Click on users >Edit the user >From the "select bot running device section", select the device and move to the right
 



7. Login with Admin user to your control room >Click on Administration ->Click on roles >Edit the roles which are assigned to the affected user >Click on Run as select the device and move to the right.
 



8. Delete the registration.properties file found in C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere from the user level and connect to bot agent

Additional Information

While deploying bot on RDP or Console, it is important to set the correct Deployment Type
If the deployment type is set as RDP, but you are deploying on console (for eg. laptop or desktop), the deployment would fail with the above error and even after setting the device credentials, it will not work. You can check the session type, i.e. console or RDP, using the command query session in the command line

Badge +1

Hi @Padmakumar ,

 

In fact, I am unable to log-in to that portal. I need to check with my team regarding the reason.

 

By the way, thanks a lot for the support.

 

 

Userlevel 7
Badge +12

Hi @Padmakumar ,

 

In fact, I am unable to log-in to that portal. I need to check with my team regarding the reason.

 

By the way, thanks a lot for the support.

 

 

You may need to use your organization/official mail id for the registration and logging in. You might be using your personal mail id through which the access will be restricted.

Badge +1

Oh yeah...You are right. I used my personal id for logging in. Thanks for reminding.😁

Reply