Question

Universal Recorder. Recorder has experienced an internal error.

  • 16 February 2023
  • 7 replies
  • 1431 views

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So I was using Universal Recorder for recording the steps and as I started and clicked the object, it gave me an error: - Recorder has experienced an internal error. Please stop recording and try again 

Steps for troubleshooting I have already performed, but none worked are:-

  1. Reload the window and try to record again, but no luck.
  2. Tried logging out and logging in again, but that didn’t work too.
Error screenshot

Please help me with this. I am very new to this with no experience.


7 replies

Userlevel 1
Badge +7

Hello,

 

Have you tried this workaround ? https://apeople.automationanywhere.com/s/article/Recorder-has-experienced-an-internal-error-Please-stop-recording-and-try-again

Userlevel 7
Badge +13

Hi @RpaDeveloper999 ,

 

Kindly confirm your A360 build version. 

Userlevel 5
Badge +14

@RpaDeveloper999 

Title

Recorder has experienced an internal error. Please stop recording and try again

Summary

For Automation 360.x only

AI Sense Recorder crashes with the error: 'Recorder has experienced an internal error. Please stop recording and try again.'

Cause

AV was blocking files/dlls being used by the Recorder. Trend Micro (AV) in particular was found to affect the recorder and cause crash while using AI Sense Recorder.

Resolution/Workaround

Whitelist all Automation360 folders within AV:Paths to be whitelisted:
* C:\Program Files\Automation Anywhere\Bot Agent
* C:\ProgramData\AutomationAnywhere\GlobalCache\embedded-resources
* C:\ProgramData\ABBYY
* C:\Program Files\ABBYY SDK
* C:\Users\<useid>\AppData\Local\AutomationAnywhere 
* C:\Windows\System32\Windows.Media.Ocr.dll
* C:\Windows\System32\config\systemprofile\AppData\Local * C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere *C:\ProgramData\AutomationAnywhere\

Note: <userid> refers to the user that is being used in the runner/Creator device. It has to be updated accordingly, before adding those paths to Antivirus whitelist.

Badge +1

Thanks Everybody. Now its Working.😊😊

Userlevel 5
Badge +14

@RpaDeveloper999  can you mark it was solved or best answer so that in future if any one search this topic will know what was the resolution. 

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Hi, 

Im getting a similar issue but without using AI Sense. I am using the Record: Capture Command to attempt to interact w/ Epic (healthcare app) but getting the same issue. 

The page is fully loaded and I am trying to click through some buttons but get this error message when trying to use the recorder to set the action to click. 

 

 

FYI - I am using the free community version. 

I saw the comment on whitelisting but not sure how to do that, can anyone provide further guidance? 

Thank you!

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Hi all.
 

I just had the same problem. Just for future reference in case you need it, i solved the problem changing the package versión in the next way:

  1. Go to the three dots menu and select Packages


     

  2. Then select the Recorder Packages

 

 

  1. Finally select a previous versión and click on change version button

 

 

That's the way I could solve it. I hope I could help anyone.

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