Question

Unable to read unread emails in the loop to get the attachment


Badge

I’m to connect the email using EWS server and trying to read the unread emails to get the attachment inside loop

BOT is able to connect the outlook and when loop starts bot is getting completed with following error, added delay but still getting same error. any suggestions please

Error msg : It maybe due to the following reasons :
    1. Your Internet Connection is low.
    2. A Temporary Internal Exchange Server Error occurred.
    3. Connection Reset
Please try again.


3 replies

Userlevel 5
Badge +9

@Sai 7227 

Are you using Outlook or EWS?  

If you are using EWS,  try the following:

1. Go to browser settings
2. Privacy and Security- Site settings
3. Check for option: Pop-ups and Redirects
4. Click on Allow (if not already allowed)

(or)
1. Click on Control Room URL SSL option to go to Pop-ups shortcut
2. Select Allow

Re-open browser and try to test connection. We should see a pop up with it's respective message.

HTH

Regards

Badge +2

@Sai 7227@Raul Jaimes Checking in on this issue as I’ve just started running into this same issue this morning all of a sudden.

Were either of you able to test this solution and determine what solves the problem?

Badge +2

UPDATE: For all who end up here with the same error message as above, in case it ends up being helpful my particular situation was caused due to unicode characters/symbols being used in specific email parts (subject/body).

I do not have a permanent solution, but have been able to give my internal teams this info so they can use a temporary solution by removing/deleting these emails to allow automation’s to continue to run.

Finally, I intend on submitting this to AA Support as a potential bug they can document and hopefully determine a permanent solution to.

Reply