Solved

Unable to connect to to Excel DB

  • 26 December 2022
  • 6 replies
  • 72 views

Badge +2

I am facing an issue with the Excel Database connection operation with one of the processes where repeatedly getting the error message as “Could not connect to Database. External table is not in the expected format” while trying to connect to the Master file. The same file, being able to open through Excel Advanced Open command at the same time. This issue came across only after combining all Child BOTs into the Main BOT. The issue is not facing when I run that process separately.

icon

Best answer by Padmakumar 26 December 2022, 11:00

View original

6 replies

Userlevel 7
Badge +12

Hi @vincet.earnest ,

 

Let's try with the basic things first. Please confirm the below points to give better feedback on this.

 

  • Have you installed the Microsoft Access Database Engine 2010 Redistributable driver? If yes, what is the bit version of it?
  • What is the Connection mode given?
  • What is the Connection string given?
  • Have you mentioned the Session names correctly everywhere?
Badge +2

Hi @Padmakumar ,

 

Thanks for the response. Please find the requested details.

  • I have already installed the Microsoft Access Database Engine 2010 Redistributable 32-bit version.
  • Connection Mode - Default.
  • Connection String :

Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\VEarnest\RPA Practice\Audit Expeditures.xlsx;Extended Properties="Excel 12.0 Xml;HDR=YES"

  • Yes, session names are correctly mentioned.
Userlevel 7
Badge +12

Hi @Padmakumar ,

 

Thanks for the response. Please find the requested details.

  • I have already installed the Microsoft Access Database Engine 2010 Redistributable 32-bit version.
  • Connection Mode - Default.
  • Connection String :

Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\VEarnest\RPA Practice\Audit Expeditures.xlsx;Extended Properties="Excel 12.0 Xml;HDR=YES"

  • Yes, session names are correctly mentioned.

 

Ok. Then, kindly try after changing the Database package version in both Parent and the Child bots.

Badge +2

How can I do that? If you don’t mind, could you please help me with the screenshot?

Userlevel 7
Badge +12

How can I do that? If you don’t mind, could you please help me with the screenshot?

 

Open the respective BOT and click the 3 dots on the top and select the Packages from the dropdown list.

 

Select the Database package from the next window and choose the Package version from it.

 

Finally, select the Change version option.

 

Hope this will help.

Badge +2

Hi @Padmakumar ,

 

Thank you for the assistance. It is working after changing the package version. 

Reply