Question

Unable to connect and delete device to CR in community edition AA360. How do I resolve it ?

  • 2 November 2022
  • 3 replies
  • 60 views

Unable to connect device to CR, it gives the following error-"System allows only a single device to be registered. If you need to replace your existing device you should delete it first."

 

Tried to delete the device from CR, it gives the following error - "Cannot delete device, as it is part of an active bot deployment"

 

Also there are bots pending in Activity-->In Progress which did not move to historical activity tab.

 

The screenshots of the errors is given in the order as stated above.Unable to connect local device to CR 

Unable to delete device from CRPending bots in In Progress Avtivity 

Resolution tried but not worked:

  1. Restarted the bot runner machine several times.
  2. Uninstalled bot agent and reinstalled it again.
  3. Tried to authenticate using CR API but POST does not when provided with CR URL *(If there is workaround with API please let me know as I do not have much idea how to implement it)*
  4. Read various articles but was of no use, did not solve the issue.

 

Any help will be appreciated.

Thanks in advance!


3 replies

Userlevel 4
Badge +8

Hi @Sausthava Goswami​ ,

 

Please perform the device reset using the API as mentioned in the following document - https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress-Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on-A2019-CLOUD-environmentsusing your credentials.

 

If you are still facing an issue then kindly create a support case.

 

How to create a support case :

https://apeople.automationanywhere.com/s/article/How-to-create-a-support-case-in-service-cloud

 

If you don't have access to the above link, email the AA Support team "apeopleopsteam@automationanywhere.com" to get the access

Userlevel 1
Badge +2

Hello everyone,

 

Please help what is the correct use of the API v2/devices/reset endpoint found in the following article: https://apeople.automationanywhere.com/s/article/BOT-struck-in-In-Progress -Stage-and-not-able-to-move-it-to-history-or-BOT-struck-in-Pending-execution-Stage-and-not-able-to-move-it-to-history-on -A2019-CLOUD-environments

 

After successfully authenticating through the API Auth endpoint, I went through the procedure to reset a device based on its ID, but I get error 400 Bad Request "Reset type not set."

I have tried if it is due to syntax or data type in the following ways but it does not work

Is there a parameter missing from the POST request?

Option 1: With brackets and quotes

{ "deviceIds": { "ids": ["406"] }}

Option 2: With brackets and without quotes

{ "deviceIds": { "ids": [406] }}

Option 3: Without brackets and without quotes

{ "deviceIds": { "ids": 406 } }

 

v2/devices/list

v2/devices/reset

 

Note: I have carried out the process in Automation 360 Community Edition, which is where it does not allow deleting the device due to the error "Cannot delete device, as it is part of an active bot deployment", but the progress table is empty, I also ran the procedure in Automation 360 On-Premise getting the same result: "Reset type not set." Thanks for the help, I was looking in the documentation, but I can't find anything else related to the use of v2/devices/reset

 

Thank you very much for the help, I stay tuned

 

Best regards,

Userlevel 7
Badge +10

Hi @BOT.DEV & @Sausthava.G ,

 

Please check the API Query which you are trying to execute. Below is the correct syntax

 



 

Reply