Question

SAP : Error in communication (invalid shared memory)

  • 7 December 2022
  • 9 replies
  • 1494 views

Badge +1

Anyone experience the following error in SAP while bot is running:

 

Error in communication (invalid shared memory)

 

Since this error occurred multiple other SAP related issues started including flashing popups screens, additional menus not loading is full etc. 

 

If anyone else has experienced this before and manage to get it resolved please advise. 


9 replies

Userlevel 7
Badge +13

Hi @Bianca.M ,

 

It is something to do with Memory Management. What I suggest is, if you have huge number of records to process, after some number of records get processed, kill all the application used and restart them. Killing application releases memory held for the process. I guess this should solve your problem.

 

One more suggestion I can give you here is, remove the overwrite option for the screenshot saving (if you are using it) whereby saving file uniquely by creating file name with system variables (day, month, year, hour, minute, second and millisecond).

Badge +1

Hi Padmakumar,

 

Thank you for the reply.

 

The bot automatically kills all programs and restarts on failures, however after restarting on the first transaction it will fail again. It seems to be intermitted and in no specific area although many concurrent switches on dropdowns does cause this failure easier. 

 

I am sure this error is a SAP error and not a bot error (as all the other problems only started after this happened) and the follow up message you receive once you click on is “RRP: Compression error [rc=]-program will be terminated” with a SAP GUI for Windows 770 header. It has also been running fine for the last month on the exact same sequence and with the same volumes without any issues.

 

I am not using screenshots. 

 

If you have any other advise please let me know. 

Userlevel 7
Badge +13

HI @Bianca.M ,

 

Curious to know how you are recoding the Error screen shots.

Userlevel 3
Badge +6

Dear @Bianca.M,

 

This error can occur when the SAP system is unable to handle the amount of data being processed, which can happen when there are a large number of concurrent transactions or when there are issues with the network connection.

To troubleshoot this issue, I would recommend trying the following steps:

  1. Check the network connection to ensure that it is stable and not experiencing any issues.

  2. Try reducing the number of concurrent transactions to see if that resolves the issue.

  3. If the issue persists, I would recommend reaching out to SAP support for further assistance. They will be able to provide more detailed troubleshooting steps based on your specific system and configuration.

In general, it is always a good idea to regularly check for updates to your SAP system and apply them as needed to ensure that you are running the latest version with the latest bug fixes and performance improvements.

 

Regards,

Userlevel 5
Badge +9

@Bianca.M 

Contact your SAP Basis and try to identify something in the SAP logs. The memory provided for the process dont seem enough for the amount of data. Probably needs a flush of memory. Try to handle a less data and see the behaviour.

https://answers.sap.com/questions/3969046/invalid-shared-memory-key34.html  (kind of old)

https://blogs.sap.com/2014/06/06/shared-memory-sharing-objects-across-programs/

 

Regards.

 

 

Badge +3

Hi @Bianca.M ,

 

Did you solve your issue ?

I’m currently experience the same as you with SAP..

 

Thanks in advance for your feedback.

best Regards,

Olivier

Badge +1

Hallo,

 

There has been a lot of changes we have tried since the error, with the SAP basis team, but no resolution as yet.

 

We have enabled trace files in SAP and we will see whether the trace files can provide us with any solution.

 

I will keep you updated.

Badge +1

Hi Bianca,

Have you got any solution for the same. We are also getting the same error.

Appreciate if you can share solution if your have found.

Thanks & regards,

Manish

Badge +2

HI guys, 

we are having also issue with SAP automation that needs to process bigger files - with more lines in SAP.

I was testing it couple of times and once I saw the ‘invalid shared memory’ error pop up but despite that the bot was able to process bigger file. But this was only one off situation. Usually automation cannot process the bigger files and in logs I see the following error too: An unexpected error occurred. COM object method returns error code: 0x8000000A; The data necessary to complete this operation is not yet available.

SAP support is saying that it is not related to SAP, I think it is not related to AA. Do someone happen to have  idea where the issue can be? :)

 

Thanks

Reply