Question

Problem with the action DataBase Connect


Badge +3

Hello community, please I need your help and expertise.

Currently I want import data from my sql server to csv file, but I am receiving this error:

     “Cannot find any Connect command using session name 'Default'”

 

 

I was checking some way to verify if the “Default” session is configurate but I cannot find anything in the control room.

¿Can you help me somebody please?  🙏🏼


20 replies

Userlevel 4
Badge +7

Hi @erickbenitez ,

Could you try placing a String variable instead of the Default value into the Session Field?
If that doesn’t work, then the other option is to downgrade/upgrade the package and see if that resolves the issue.

Kind Regards,
Ashwin A.K

Userlevel 7
Badge +13

Hi @erickbenitez ,

 

Could you please share what's there in line 25?

In case you have mistakenly put the Disconnect command inside the loop, please move to the end of the BOT and try again.
 

Userlevel 2
Badge +4

Good point @Padmakumar i was thinking the same…

L25 would help to have a look at.

Badge +3

Hi @erickbenitez ,

 

Could you please share what's there in line 25?

In case you have mistakenly put the Disconnect command inside the loop, please move to the end of the BOT and try again.
 

 

Thanks @Padmakumar and @Marc 1985 

This is the line 25:

 

Currently the action disconect is outside of the loop. The error continue...

Badge +3

Hi @erickbenitez ,

Could you try placing a String variable instead of the Default value into the Session Field?
If that doesn’t work, then the other option is to downgrade/upgrade the package and see if that resolves the issue.

Kind Regards,
Ashwin A.K

Thanks @Ashwin A.K 

I already try using string variable, but the error continue:
 

 

 

 

How I can do this: “downgrade/upgrade the package” the package DataBase Connect?

 

Thanks @Ashwin A.K 

Userlevel 5
Badge +10

@erickbenitez Have you setup this db connectivity and verified in bot runner machine ?

 

  1. Open the 64 bit ODBC Administrator:

    Windows 10 (64 bit version) supports 32 and 64 bit ODBC sources — always use the 64 bit ODBC Administrator.

    • Search for ODBC and choose ODBC Data Sources (64 bit):
      search for ODBC
    • Right Click and choose Run as Administrator:
      run as administrator
  2. Open the System DSN tab and click Add:
    odbc system dsn
  3. Choose the latest MySQL ODBC driver and click Finish:
    choose latest MySQL ODBC driver
  4. Enter the ODBC credentials:
    • Use any Data Source Name and Description you prefer.
    • Enter the Network Name (or IP) of the MySQL Server in the TCP/IP Server field:
      Note: If you are unsure of this ask your DBA (database administrator).
    • Enter the User name and Password:
      Note: If you are unsure of these ask your DBA (database administrator).
    • Optional: Choose your default Database:
      mysql odbc credentials
  5. Test the data source connection:
    • Click Test Data Source…:
      test mysql odbc
    • And if it works you are good to go:
      mysql connection successful
    • Click OK to create the ODBC data source:
      OK to create odbc datasource
Badge +3

@erickbenitez Have you setup this db connectivity and verified in bot runner machine ?

 

  1. Open the 64 bit ODBC Administrator:

    Windows 10 (64 bit version) supports 32 and 64 bit ODBC sources — always use the 64 bit ODBC Administrator.

    • Search for ODBC and choose ODBC Data Sources (64 bit):
      search for ODBC
    • Right Click and choose Run as Administrator:
      run as administrator
  2. Open the System DSN tab and click Add:
    odbc system dsn
  3. Choose the latest MySQL ODBC driver and click Finish:
    choose latest MySQL ODBC driver
  4. Enter the ODBC credentials:
    • Use any Data Source Name and Description you prefer.
    • Enter the Network Name (or IP) of the MySQL Server in the TCP/IP Server field:
      Note: If you are unsure of this ask your DBA (database administrator).
    • Enter the User name and Password:
      Note: If you are unsure of these ask your DBA (database administrator).
    • Optional: Choose your default Database:
      mysql odbc credentials
  5. Test the data source connection:
    • Click Test Data Source…:
      test mysql odbc
    • And if it works you are good to go:
      mysql connection successful
    • Click OK to create the ODBC data source:
      OK to create odbc datasource

 

 

Thanks @rbkadiyam I will try this, right now. Only one question. 

Your recomendation can work for me, if I am using SQL Server?

Thanks.

Userlevel 5
Badge +9

Hi @erickbenitez 

Try to place it in the Error Catch, not only in the Finally sentence. Probably when you are  invoking  the Connect action it sends and error and goes to finally where the database sessión is not recognized

 

HTH

REgards

Badge +3

Hi @erickbenitez 

Try to place it in the Error Catch, not only in the Finally sentence. Probably when you are  invoking  the Connect action it sends and error and goes to finally where the database sessión is not recognized

 

HTH

REgards

 

 

Ok @Raul Jaimes I will this now. I will give you a feedback. Thanks.

Badge +3

Hi @erickbenitez 

Try to place it in the Error Catch, not only in the Finally sentence. Probably when you are  invoking  the Connect action it sends and error and goes to finally where the database sessión is not recognized

 

HTH

REgards

 

 

Ok @Raul Jaimes I will this now. I will give you a feedback. Thanks.

 

 

I tried, but is the same result.. not work

Userlevel 5
Badge +9

@erickbenitez 

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

Badge +3

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

Userlevel 5
Badge +9

@erickbenitez 

Check logfiles to identify any error message. 

C:\ProgramData\AutomationAnywhere\BotRunner\Logs\Node_Manager.log & Bot_Launcher_*.log

Regards

Userlevel 7
Badge +13

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

Badge +3

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

Thanks @Padmakumar I was checking and I dont have the Error_Message and Error_Linenumber variables, I think a I need update something right?

I am sorry, my apologies for everyone, currently I am in my personal community account, Currently I am working like RPA Developer Junior but I am try to improve my skills in one test.

Badge +3

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

@Padmakumar I think get something:

 

 

Can you check please?

I think I need check something with the conection to the data base, right?

Userlevel 7
Badge +13

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

@Padmakumar I think get something:

 

 

Can you check please?

I think I need check something with the conection to the data base, right?

 

 

This is something related to the connection request to your SQL server. Please check whether you are having proper access permission or not.

Badge +3

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

@Padmakumar I think get something:

 

 

Can you check please?

I think I need check something with the conection to the data base, right?

 

 

This is something related to the connection request to your SQL server. Please check whether you are having proper access permission or not.

 

 

Yes, until where I can investigate, I need put enable this option in the sql manager:
 

 

but also, the result is the same :(

 

Is possible, that this problem is because I am using automation anywhere Community Edition build 16667?

 

Thanks and thanks for your patient with me.

Userlevel 7
Badge +13

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

@Padmakumar I think get something:

 

 

Can you check please?

I think I need check something with the conection to the data base, right?

 

 

This is something related to the connection request to your SQL server. Please check whether you are having proper access permission or not.

 

 

Yes, until where I can investigate, I need put enable this option in the sql manager:
 

 

but also, the result is the same :(

 

Is possible, that this problem is because I am using automation anywhere Community Edition build 16667?

 

Thanks and thanks for your patient with me.

 

Could you please try after changing the Database package version?

Badge +3

@erickbenitez

Thank for your feedback. Place it like in the screenshot and then move it forward accordingly. The intention is identify if exits any wrong reference 

 

Regards

 

Sorry the result is the same :(

 

 

Instead of putting a custom message inside the Catch action, please use the Error_Message and Error_Linenumber variables to see the exact error and where it is actually occurring. I don’t think the actual issue is with the Disconnect action.

 

@Padmakumar I think get something:

 

 

Can you check please?

I think I need check something with the conection to the data base, right?

 

 

This is something related to the connection request to your SQL server. Please check whether you are having proper access permission or not.

 

 

Yes, until where I can investigate, I need put enable this option in the sql manager:
 

 

but also, the result is the same :(

 

Is possible, that this problem is because I am using automation anywhere Community Edition build 16667?

 

Thanks and thanks for your patient with me.

 

Could you please try after changing the Database package version?

 

Thanks @Padmakumar  I tried changing the version for many different version, but the result is the same.

Reply