Question

Please help... "com/automationanywhere/commandsdk/i18n/MessagesFactory:

  • 15 February 2022
  • 6 replies
  • 6 views

I created one custom package and it is working fine by testing the code using test class in IntellJ. When i am using the .jar file in AutomationAnywhere.then i am getting this error. Can someone please help me on this.

 

Log-

at java.lang.Thread.run(Unknown Source) [?:?]

Caused by: java.lang.ClassNotFoundException: com.automationanywhere.commandsdk.i18n.MessagesFactory


6 replies

Check the version of java.
Badge +6

Hello! I have the same problem!!Once package is built I test it and get the same error...

 

com/automationanywhere/commandsdk/i18n/MessagesFactory

 

 

Check the Java SDK version installed on your machine and the version selected in IntelliJ. Both version should be same.



Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986>for Windows
Badge +6

You mean Java JDK?? I have version 11 installed, could you please tell me how did you solve it?

Badge +6

image.pngI have just installed java sdk version 11 and set it there, am I missing something else? Thank you

Badge +6

I was using gradle clean build instead of gradle build clean shadowJar, so the .jar file was not correct. Once I have built it with gradle built clean shadowJar all worked

Reply