Question

Microsoft Access Database Engine 2010 Redistributable - 32bit vs. 64bit

  • 19 May 2022
  • 2 replies
  • 22 views

In @MICAH SMITH​ 's video "RPA Quick Tips: How to Connect to an Excel Spreadsheet as a Database", he notes downloading the "Microsoft Access Database Engine 2010 Redistributable" as 32bit even if we're using a 64bit OS. However, when we've tried to install it, we get the error attached. It seems we would need to remove and install our whole MS Suite as 32bit in order to use it. Our IT group installed the 64bit and the bot couldn't find the database.

 

Anyone have any ideas how to resolve this, other than changing our use of the 64bit MS Suite?

 

Thanks!

JoAnn


2 replies

Userlevel 3
Badge +6

Hey @JoAnn Roa​ - did you try without installing the driver at all? I'm using a different machine from when that video was originally recorded, and I just built a bot to read from by DB without installing any drivers. Of note, I have Office365 installed...I'm not positive what impact that has on this...but my OS is 64-bit, and I hadn't installed the driver I mentioned in that video on this new machine. My connection string for reference was:

 

Provider=Microsoft.ACE.OLEDB.12.0;Data Source="c:\path\tomyexcel\file.xlsx";Extended Properties="Excel 12.0 Xml;HDR=YES";

Hi @MICAH SMITH​, I probably should've mentioned we're using MS Office 2010, which I think is the issue. My IT group replaced the 64bit version of Office with the 32bit and then installed the 32 bit driver. Then my bot worked (so awesome!). Our lead dev had tried it initially and received the same error I attached previously during installation.

 

Thanks for pointing out the MS Office version. It probably would be a good idea for our IT group to update us to something a little younger than 12 years old!

 

JoAnn

Reply