Question

Insert more then one case into postgresql error pops

  • 4 January 2024
  • 2 replies
  • 20 views

Badge +4

When I run more then ten cases at time in a batch to insert data into a postgresql DB I get the below error(in the attachment), however when I run the bot to insert one case with a hard coded value it insert the case, so it can’t be a syntax error, if I’m using the same cases to insert it into the postgresql DB.The process worked for over two months only today it had an issue.Nothing in the code had changed from 2months ago.Below is the error message any suggestions will be helpful-Thanks


2 replies

Userlevel 3
Badge +8

Hello @Lesley,

Since there is no change in the code from last 2 months and to rule out duplicate sessions issue, Let's try cleaning up the local temp files on the machine that bot is trying to connect, This will help us verify that there aren't any duplicate sessions causing problems. 

Thanks. 

 

Userlevel 7
Badge +13

Hi @Lesley ,

 

Could you please provide the INSERT query? Also, I would recommend building the query on SSMS to double verify that it is Syntax error free.

 
 

Reply