Question

I still get the error: UNKNOWN: User: (username) is already running a bot on the device: If the problem persists, contact your system administrator. Can anybody help me?

  • 28 September 2022
  • 4 replies
  • 235 views

URL:

https://community2.cloud-2.automationanywhere.digital/

 

I have run a bot and it stayed very long time without execution so I just clicked on Cancel.

Then I tried to run it once again, and it gives me the following message:

//

UNKNOWN: User: (<user_name>) is already run

ning a bot on device: (<device_name>)

//

 

I tried also to delete the device but it gives me the following message:

//

Cannot delete device, as it is part of an active bot deployment

//

 

So, I have tried the following action without any success in resolving the issue:

 

1 - Restart the "Automation Anywhere Bot Agent" service.

2 - Stop and then Start "Automation Anywhere Bot Agent" service.

3 - Uninstall and install the agent.

4 - Uninstall and clean the AA folders in the profile and install with admin the agent.

5 - Restart the computer

6 - Leaving the computer shut down (clean shut down with no sleep and no hibernation) for 1 night.

7 - Installing an older version of Automation Anywhere Bot Agent.

 

These steps did not resolve the issue.


4 replies

Thank you Brandel for emphasizing my message.

 

I still have the same issue since 6 days and still not resolved.

I am really frustrated and can not wait to be hindered any longer.

This is an alert that I can not count on the AA community edition to run my day to day bots as individual.

Therefore, even if the issue is resolved, this was a serious hit, and red flag that cloud solution has its own great advantages but also has its own killing disadvantages, which raise the bar for the desktop solution.

 

What I have learned is:

Cloud Deployment + Prompt Support = Great Solution

Cloud Deployment - Prompt Support = Not a Solution

 

Kind Regards,

Fouad Sabry

Hello,

 

I had the same exact error but it maybe possible the root cause for this same error could be different to all of us facing this error.

 

I had to restart bot agent service in services.msc and post that it works fine. It is also interesting to note that, it does make the error to go away but comes back again if the bot is stopped midway. So, I have been restarting bot agent service every time i get the error which is annoying but at least I am not completely blocked.

Badge +2

Hi Brandell,

 

Did you manage to resolve it?

 

If yes, please let me know how you managed to do it because I’m also experiencing the same issue as you.

 

Thank you.

Userlevel 4
Badge +9

@Anthony Yeo 

 

Remove automation anywhere folder under 

C:\Windows\System32\config\systemprofile\AppData\Local

Then restart your machine.

Reply