How to solve "There is a syntactical error in the SQL statement."

  • 31 March 2022
  • 9 replies

User is able to connect to database, do select queries but all insert queries got the same error.


Using Automation Anywhere 360 version an as database Access

9 replies

Userlevel 6
Badge +15

Please double-check the queries, sometimes white space or hidden spaces cause these issues.

Userlevel 6
Badge +16

Hi @Alejandra Bonilla​ ,


Few tips for working with SQL Statements, build the Queries using SSMS and try to copy the Query from SSM to A360 and try running the bot. Keep a message box and check the values before DB commands to make sure values are available in the respective variables before hitting the DB commands.

Badge +5

What is the solution for this? What is the correct insert query statement


i ran the update query in compiler, but still not working in AA :(


UPDATE [Dx_Orders$$] SET "Material issue Date" = '$vPostingDate$' WHERE "Sales Document" = '$vSalesDocMaster$'


Getting error as -

 There is a syntactical error in the SQL statement.

- SQL statement got timed out.


Can someone help ?





Same issue, INSERT query was working fine but caused only once and keeps on failing after that.


Userlevel 7
Badge +13

Hi @rohit.k1,


Could you please share your INSERT query and the output that you are getting from it?

It is a best practice to keep a message box just Infront of the INSERT query through which you can identify the issue with the syntax and ensure the data is populating correctly or not.



Userlevel 3
Badge +6

Dear @AlejandraBonilla,


There could be several reasons why you are experiencing an error when trying to perform insert queries using Automation Anywhere 360 and an Access database. Here are a few things you can try to troubleshoot the issue:

  1. Make sure that you have the necessary permissions to insert data into the database. If you do not have permission to insert data, you will receive an error when trying to perform an insert query.

  2. Make sure that the syntax of your insert query is correct. Access uses a specific syntax for insert queries, and any errors in the syntax could cause the query to fail.

  3. Make sure that the data you are trying to insert is valid. If you are trying to insert data that is not in the correct format or exceeds the maximum length of the field, you may receive an error.

  4. Check the log files for any error messages that may provide more information about the cause of the issue. You can find the log files by going to the "Logs" tab in Automation Anywhere 360 and selecting the appropriate bot from the list.



Badge +1

Problem: Database Insert command not working in Community Edition.

Error: There is a syntactical error in the SQL statement. - SQL statement got timed out.


I am using the AA Community edition. I am trying to Insert data into MS Access db. from excel.xlsx but getting an error.

My MS  access db. is connecting. I tested my DSN connection. Only the INSERT query not working. Value are populating in all variables and SQL query.

INSERT INTO Test Values(‘$Report_Name$’,‘$RPA_Operator$’,‘$RPA_Operator_Email$’)

-MS Access data types are correct . MS Access data types are

Report_Name = Short Text

RPA_Operator= Short Text

RPA_Operator_Email= Long Text

- Using MS Office 2016 professional edition, 32-bit.

- ODBC driver successfully installed and connected 32-bit.


I successfully ran the same query in the Query design in MS Access which ran successfully and inserting data into db. table field.  

Please let me know if you have any questions. Thank you.

I also emailed on "" to get solution/ access, still waiting for a reply. Please help. Thank you.

Userlevel 4
Badge +6

INSERT INTO Test Values(‘$Report_Name$’,‘$RPA_Operator$’,‘$RPA_Operator_Email$’)

Have you tried putting the column names in as well? There are no apostrophes in any of the fields?