Solved

Chrome Update 121.0.6167.86 Issues

  • 24 January 2024
  • 22 replies
  • 720 views

Badge +1

Since Chrome has updated most of our bots no longer work.  Any interaction with text fields don’t produce the results we were previously experiencing.  I created a small bot to open Google in Chrome and enter a search term for Todays Weather, but that basic bot doesn't even work.  I have attached the bot to this post and was wondering if anyone else is experiencing the same issues?

Cheers

Dwayne

icon

Best answer by ChanduMohammad 25 January 2024, 09:49

View original

22 replies

Badge

We also have the same issue with Chrome (Version 121.0.6167.86 (Official Build) (64-bit)) all the recorder lines with the action left or double click are not working well, to fix it, we change that lines to “click” action, but in other cases we’ve needed to recapture it, for example in set text action.

Badge

We also have several developments that have been totally impacted by the update to this version of Chrome. We have seen a multitude of anomalies detected in the recorders:

- recorder actions with left click and double click do not work correctly

- recorder actions with set text do not dump the text

We suspect that the incident has to do with some type of spatial displacement that occurs when trying to activate or click on an item because we have observed that when a recorder does not work properly, the bot clicks on the wrong point on the screen.

Badge

Our vendor has confirmed that any of their VM’s that update to the latest version of Chrome render their bots unusable.

They cannot enter text or navigate on the webpages.

I have a severity 1 case open with AA360 as unfortunately Chome does not allow you to go back a version and currently our PROD environments are all down as the bots cannot navigate.

Hopefully a fix is available asap.

Userlevel 5
Badge +12

We have the same issue all Prod bots are down, placed FATAL ticket with AA waiting for the fix 

Userlevel 5
Badge +12

Hi All,

Checkout the KB

Badge

Has anyone tried a short term fix of switching from using chrome to a different browser, like Microsoft Edge?

Badge

Has anyone tried a short term fix of switching from using chrome to a different browser, like Microsoft Edge?

We’ve downgrade the Chrome version to 120, after that everything works well

Badge

Has anyone tried a short term fix of switching from using chrome to a different browser, like Microsoft Edge?

We’ve downgrade the Chrome version to 120, after that everything works well

Do you have steps to downgrade? The below link was not help to me

https://support.google.com/chrome/a/answer/7125792?hl=en#zippy=%2Cstep-downgrade-chrome

 

Badge

Olá, 

Alguém utilizando Windows Server conseguiu através do link? https://support.google.com/chrome/a/answer/7125792?hl=en#zippy=%2Cstep-downgrade-chrome

 

Obrigado

Badge +5

Hello Everyone!

If the problem still persists, I would recommend that you submit a formal support ticket so of our support members can assist you with this. 
To submit a support ticket, visit the Support Portal.  (LINK)

If you are unable to access this page, please reach out to your account representative for troubleshooting assistance. 

Rima Sengupta

Pathfinder Community Team
 

Badge

Has anyone tried a short term fix of switching from using chrome to a different browser, like Microsoft Edge?

We’ve downgrade the Chrome version to 120, after that everything works well

Do you have steps to downgrade? The below link was not help to me

https://support.google.com/chrome/a/answer/7125792?hl=en#zippy=%2Cstep-downgrade-chrome

 

We have an offline installer, used on Windows Server 2019

 

Badge +4

If anyone is still looking for a workaround for this issue on Windows Server, please investigate the possibility of using a server snapshot (if your company stores them) to roll back to chrome version 120.

Once the server has been rolled back, you will need to disable Google Chrome automatic updates to prevent version .121 from being installed automatically again: ‘https://support.google.com/chrome/a/answer/6350036?hl=en#zippy=%2Cturn-off-chrome-browser-updates

 

This has worked for my organization, I hope this can help someone 🤞

Badge +1

Hi All,

Checkout the KB

These instructions are for Google Workspace and Chrome Browser Enterprise Support customers only

I just want to downgrade a standalone PC.  Cannot find any instructions on how to do it.  Any ideas?

Badge +1

Has anyone tried a short term fix of switching from using chrome to a different browser, like Microsoft Edge?

I switched to bots to use the default browser which I made Chromium on the bot runner, but you still have to go into each bot. Not a good solution.

Userlevel 5
Badge +12

Hi All,

Checkout the KB

These instructions are for Google Workspace and Chrome Browser Enterprise Support customers only

I just want to downgrade a standalone PC.  Cannot find any instructions on how to do it.  Any ideas?

Hi @User16594604096479542004 

If you are cloud customer try changing package version to latest one ie 2.17.2 in the task bots and give a try. If you are using On Prem or unable to see this package refer above KB to manually download and Upload the same to the Control Room-> Manage-> Packages-> Add package

 

Badge +2

hi, we downgraded chrome but it didn’t help, is there any other solution than upgrading recorder package? thank you

Badge +1

Upgrade the recorder worked with the latest version of chrome.

I am curious what is the best practice for avoiding these issues in the future. 

Do most enterprises run their bots on Chromium so they can control updates?  Do they turn off Chrome updates and periodically test all their bots on the latest version and they release it?

Or is what just happened a very rare situation and most enterprises just wait for a package update?

THANKS FOR ALL YOUR HELP!

Badge +1

The other issue we experienced is that the new package needed to be applied to > 150 bots, so we used the Update Bot process to update the packages of those bots.  Unfortunately, there is new functionality for setting timeouts when accessing a DOM element using the Recorder and this caused a lot of these bots to require manual updating (as they were using a recorder package without this functionality) so that they were able to work again.

It would have been preferable if the update process was able to default to Basic and use the value that was previously entered.

Badge +7

The other issue we experienced is that the new package needed to be applied to > 150 bots, so we used the Update Bot process to update the packages of those bots.  Unfortunately, there is new functionality for setting timeouts when accessing a DOM element using the Recorder and this caused a lot of these bots to require manual updating (as they were using a recorder package without this functionality) so that they were able to work again.

It would have been preferable if the update process was able to default to Basic and use the value that was previously entered.


Hallo @dwilks73 

and that’s what exactly happening, when switching to new package the action takes the previous time as basic value...

Badge +1

The other issue we experienced is that the new package needed to be applied to > 150 bots, so we used the Update Bot process to update the packages of those bots.  Unfortunately, there is new functionality for setting timeouts when accessing a DOM element using the Recorder and this caused a lot of these bots to require manual updating (as they were using a recorder package without this functionality) so that they were able to work again.

It would have been preferable if the update process was able to default to Basic and use the value that was previously entered.

Hallo @dwilks73 

and that’s what exactly happening, when switching to new package the action takes the previous time as basic value...

The Basic option is selected and the Wait for system response (in seconds) is blank.  I would have expected that this is filled in with the previous value, but it isn’t, it is blank so the entire bot is invalid due to this. 

Badge +7

The other issue we experienced is that the new package needed to be applied to > 150 bots, so we used the Update Bot process to update the packages of those bots.  Unfortunately, there is new functionality for setting timeouts when accessing a DOM element using the Recorder and this caused a lot of these bots to require manual updating (as they were using a recorder package without this functionality) so that they were able to work again.

It would have been preferable if the update process was able to default to Basic and use the value that was previously entered.

Hallo @dwilks73 

and that’s what exactly happening, when switching to new package the action takes the previous time as basic value...

The Basic option is selected and the Wait for system response (in seconds) is blank.  I would have expected that this is filled in with the previous value, but it isn’t, it is blank so the entire bot is invalid due to this. 

hmh, that’s strange… What package number You\re introducing and are Youc Cloud user or on-prem?

Badge

Short term solution is for critical automations open bot in private tab and go to packages and change recorder version of package from not default to default version. i tried and it’s working now.

Reply