Question

Can't build after deleting sample commands with SDK 2.5.0?

  • 24 May 2023
  • 0 replies
  • 128 views

Badge

Hello,

 

I’ve been working with the A360 package SDK for a few months now (among other projects, so not continuously), and have been so far unable to solution for a problem that’s been bothering me quite a bit. 

 

I have had a good bit of success creating my own actions, mostly performing some custom web interactions with Selenium, but for some reason when I try to delete all of the sample commands that come zipped up with the SDK, I lose the ability to build. I narrowed this down to specifically FindMaxMinNumber, and was able to delete the rest of the command classes successfully but the moment I delete this class, my build fails with the following error message: 

Execution failed for task ':compileJava'.
> com.automationanywhere.commandsdk.processing.ProcessingException: Incorrectly typed data found for annotation element public abstract com.automationanywhere.commandsdk.annotations.CommandPkg$Returns[] com.automationanywhere.commandsdk.annotations.CommandPkg.multiple_returns() (Found data of type com.automationanywhere.commandsdk.annotations.CommandPkg.Returns[])

 

I have tried a million different things as suggested by the only other related topic that I was able to find 

but none of them have been helpful. I do have some void actions that are decorated with @Execute, so was hopeful that I would find some success in that thread, but I did not. I have confirmed that my project is building with Java 11, which was the eventual solution found in that thread. I also tried the alternative presented to change the void actions to return optional BooleanValues with no success.

 

I have resorted to trying to trim back all of the other actions and classes I created, and am trying to build a totally new project with just one command, and a corresponding test file. That command’s annotation details appear below: 

 

The only thing that allows my project to build is by reinstating FindMaxMinNumber.

 

I am primarily a C# developer, so gradle is a bit outside of my wheelhouse, but I feel like I’m losing my mind trying to figure this out. Every week or so I sit down and spend a handful of hours trying to get out from under this thing, but each time I come away defeated with a label on that action saying that it’s not supposed to be in there and get back to working on other stuff.

 

Thanks in advance for any suggestions or help!

 

Evan Baule

Senior Software Engineer, R1 RCM

 


0 replies

Be the first to reply!

Reply