Question

unable to delete device for community edition showing the error devicemanagement.register.validation.single.device

  • 6 December 2022
  • 7 replies
  • 1168 views

Badge +1

In the community edition i am not able to delete the device. I am getting the below error when i tried removing the device using mange tab.

Cannot delete device, as it is part of an active bot deployment

If the problem persists, please contact your system administrator.

When i am trying to connect device it is showing the below error

System allows only a single device to be registered. If you need to replace your existing device you should delete it first.

If the problem persists, please contact your system administrator.

Code: devicemanagement.register.validation.single.device

 

Can any one guide how to delete device using admin login option in community edition? or support contact of admin who can help to delete the device?


7 replies

Userlevel 4
Badge +7

Hi @P KarurS102205 ,

->Try restarting the Bot Agent first, and see if that helps.
->If that doesn’t help, then you can try deleting the device now, because it won’t be a part of any active deployment(since you restarted the agent responsible for deploying automations onto machines and untold misery upon developers in case something goes wrong)
->If that doesn’t work either, then try reinstalling the Bot Agent after uninstalling it first(duh) and head over this this location C:\Windows\System32\config\systemprofile\AppData\Local\Automation Anywhere  right here and delete the registration properties...and everything else because I’m not sure which file I was supposed to delete.
->If that doesn’t work either…

It was a pleasure meeting you.
*Runs away*

Kind Regards,
Ashwin A.K

Userlevel 6
Badge +10

@P KarurS102205 I want to flag that we have moved this discussion to our dedicated Community Edition group. 

Badge +1

Hi Ashwin - Thanks for responding the query. I tried restarting and reinstalling the BOT agent but still i am not able to remove the device. Not sure if some issue with community edition as normally it allows to remove the device. Do you know support team /admin team of community edition who can help in deleting the device from back end?

Userlevel 6
Badge +16

Hi @P KarurS102205 

Can you try one more step, uninstall bot agent this will remove all the existing mapping and navigate to Devices section see if there is any device entry if yes please delete it give a shot?

Userlevel 3
Badge +6

Dear @P KarurS102205,

 

We have different scenario when we cant connect to device are following:

  1. Reinstall the bot agent with latest version
  2. Restart the bot agent services
  3. Make sure AA certificate for control room is added in your local machine 
  4. Restart the machine 

Regards,

Badge

Please follow below youtube video.

 

Userlevel 7
Badge +13

Hi @P KarurS102205 ,

 

Please refer the below thread and try to reset your runner device through API call.

 

 

Reply