Question

a2019 community - Error while recording - "your chrome plug-in is either not installed or disabled. For trouble-shooting help, visit the automation anywhere documentation and search for 'chrome plug-in".


aa plugin issueUsing a2019 community edition. Getting error while capturing object as "your chrome plug-in is either not installed or disabled. For trouble-shooting help, visit the automation anywhere documentation and search for 'chrome plug-in". 

  • Plug in version is v 11.x.x. 
  • Already tried uninstalling/reinstalling/restarting system
  • Also viewed the documentation page of apeople. But couldn't find the HKEY file stated in that.

Is there anything else I can try to fix this?

 


23 replies

Userlevel 6
Badge +10

Hello @Ayas Mohapatra​ 

 

Please disable the extension and re-add to the chrome using the link of chrome store mentioned in the below article and check for other parameters and let us know :

 

https://apeople.automationanywhere.com/s/article/Unable-to-capture-objects-on-Google-Chrome-in-A2019

Userlevel 6
Badge +10

Hello @Ayas Mohapatra​ 

 

Attaching the PDF format for view.

The url is invalid or the page no more exists. Can you check the url and re-share please?

Thanks a lot. Manually adding the registry keys was the solution.

How do you actually add the registry keys manually? The pdf show the keys. I use regedit and can click to the right location, but then it's unclear how to add.

 

Userlevel 6
Badge +10

Hello @Elio Mariani​ 

 

Please refer the below links which could help to add registry keys manually :

 

https://www.computerhope.com/issues/ch001349.htm

 

https://www.lifewire.com/how-to-add-change-delete-registry-keys-values-2625145

Hello -

I think the first key is there, but I do not have an extensions folder in "Google\Chrome". I only have a "NativeMessagingHosts" folder there. Do I need to create an "Extension" folder? If so how?

Can you provide better instructions? Manually editing registry keys isn't something that people should need to do.

 

Follow on question. Once I create the folder, how do I add these?

 

Also, that "update_url" registry seems like the url is cut off. Is that correct, and if so, what letters are missing?

 

@Elio Mariani​ Yes, I created extension folder manually. If the update_url is not working, you can delete and add one and then put the required file path. For file path, you need to search for the files stated in the data column. I followed the pdf shared by Vivek and it was easy for me.

Simple steps:

  1. Go to Reg Key edit
  2. Go the folders mentioned in the pdf
  3. Add the folder if not existing
  4. Edit/Add the keys using the name, type and data(file path) stated in the pdf

Hello @Ayas Mohapatra​ , what keys did you add?

I added the ones mentioned in the pdf, but the capture only takes the browser search bar and its tabsCapture

seems like there is no support here

Userlevel 6
Badge +10

Hello All,

 

Manually addition is not necessary if the user has Admin access on the machine and while installing Agent, the necessary entries will get created. However, if the access is limited, then the registry entries are not written, then manually we have to push.

 

For further support, we request to raise a Support case with us and Engineer could assist you to check more.

 

Regards,

Vivek

I tried everything posted above and unfortunately none of that worked for me.

 

Finally got AA Recording to work, using the steps as described below.

 

Hope that this helps you too.

 

 

*** ONLY consider the following if you're comfortable navigating the registry and system folders.

 

##############################################################

 

 

We need to remove all traces of Automation Anywhere (AA) on PC as follows:

 

1) Uninstall the AA Bot Agent Service.

 

2) Remove the Chrome Extension. Ensure that all versions of AA Extension are removed from Chrome.

 

3) Restart PC.

 

4) Create a Windows restore point <<< VERY Important >>>.

 

5) Using Windows explorer, navigate to the User folders and remove all instances of AA in:

5.1) "C:\Users\{UserName}\AppData\Local\AutomationAnywhere\"

5.2) "C:\Program Files\Automation Anywhere\"

5.3) "C:\ProgramData\AutomationAnywhere\"

 

6) Open the Registry editor, then FIND and Delete all references to AA (only Delete Keys and Data that contain the text "Automation Anywhere"). If you aren't familiar with Navigating, Adding, Editing, Deleting and Exporting Registry Nodes, then PLEASE get a Professional to do it.

 

7) If you use CC Cleaner, then also run that for completeness.

 

8) Restart your PC.

 

9) Install AA Bot Agent Service when you login to the AA Control centre.

 

10) Install the AA Extension from Chrome Store.

 

11) Restart the Chrome Browser and connect to local device.

 

12) Now, test one of your Bots with the Recording.

Hello @Strini Naidoo​ I got the same error, I tried everything you posted but I am getting the same error.

I am facing this issue for one month. can you please tell me how to approach AA team.

Thank you.

Hi Nari.

 

You can try to contact Support @Vyjayanthi S​ 

Maybe they can suggest another way.

 

Regards, Strini

If you have previously used V11 chrome plugin you need to perform some tweak.

https://apeople.automationanywhere.com/s/article/Your-Chrome-Plugin-is-either-not-installed-or-disabled/p>

https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/deployment-planning/cloud-chrome-changing-extension.html

Hi @Ayas Mohapatra​ ​ ,

First thing first it is not problem about plugin, it is about recorder package so please do the following steps to resolve your issue.

Please downgrade your recorder package. And try to capture element hope your issue resolved.

How to downgrade package:

Open task bot in edit mode and you would be able to see three vertical dots on top right corner, click on that and select packages, then search for recorder package and if it is in default state, please select the previous version of it and save the changes and try to capture the elements on web.

Thanks​

You can check registry as mentioned in previous comments. If that do not work then downgrade recorder activity through packages. If it is still not resolved, delete global cache from following path

C:\ProgramData\AutomationAnywhere\GlobalCache

Says Invalid url

Badge

Your Edge plug-in is either not installed or disabled. For trouble-shooting help, visit the Automation Anywhere Documentation and search for 'Edge plug-in'. Community Edition

 

 

Please suggest me the solution for this

Reply