Question

Session name already used.

  • 28 February 2022
  • 5 replies
  • 18 views

I have two task bots(A & 😎 running and scheduled at 9 AM and 3 PM. Both bots are using SAP. Bot A runs successfully but when Bot B runs. It give an error: "Session name already used. Enter a different session name and try again."

 

Can anyone please help me what I am missing?


5 replies

Userlevel 5
Badge +9

Hi @Ranish Ali​ ,

 

Can you check the Session Names in Bot B, there would be some mismatch. Run the bot in attended mode and check whether you are getting the same error or not and then go for unattended mode as per the schedule.

Userlevel 3
Badge +7

Hi @Ranish Ali​ ,

 

Ideally its best to assign Session Variables instead of passing in Local Strings.

Could you try assigning two different Session Variables to each bot and see if that works out for you?

 

Kind Regards,

Ashwin A.K

Userlevel 5
Badge +9

Can you run the bot by enabling Debug option and check in which step you are getting this error .. Hope it should be SAP command and with some other session value.

 

As a best practice use Bot Specific Session Variables instead of Default.

Hello ChanduMohammad,







Thanks for your reply. The session is set to default in Bot B.
Hello Ashwin A.K,







I’m trying to create session variable(to be used by SAP connect action), but having difficulty in figuring out what to select in Session Type Variable. Could you please assist on this?















Regards,



Ranish Ali

Reply