Question

Hi. I came across an issue regarding chrome. I have a loop (2 times) that needs to open chrome on a website, get the table and close chrome. The second time it opens chrome, it doesn't capture the table.

  • 11 May 2022
  • 5 replies
  • 15 views

The domxpath is ok, it sees the table, but it does not capture the table. It seems to me that it tries to get the table from the previous chrome tab that has been closed. I tried using the "Window-Close all" and "taskkill.exe", but still does not work.

 

Any suggestions?

 

Thank you


5 replies

Hi @Andreea Tania​ 

is the Tittle of the URL same every time, if the tittle is dynamic make use of wildcard ( * )

Ex: * - Chrome

this will help in resolving this kind of bugs

 

imageI have tried, it is working as expected. make sure you use close command available in the browser ( open window and close window )

you can use open and close commands outside the loop, since same kind of data is extracted, no need to close and open the browser multiple times

Yes, it is the same website.

 

It's weird, when the second loop comes around, it does not capture the table from the 1st page, but captures it from the 2nd page.Screenshot 2022-05-11 at 09.22.29

ohkk then above logic works the other way also just put the open and close cmds inside the loop

Thank you for your help. But the challenge is to close and reopen the browser multiple times.

 

I need to open the browser, get the table from all 3 pages, close the browser and open it again to get the tables from the 3 pages.

Reply