Question

Bot runner cannot set text in some objects on recorder action.

  • 22 December 2022
  • 9 replies
  • 69 views

Badge +7

Hi Everyone,

 

I have problem that I schedule bot runner to run process and error occured.

The error showed that bot cannot set text in some objects on recorder action.

When I remote to VM(bot runner) and let process run, it shows that bot can set text in the object that had an error before.

I don’t know how to solve this issue.

Please let me know if you have any suggestions.

 

Thank you.


9 replies

Userlevel 7
Badge +10

Hi @Gift.KP624 ,

 

Just add a Capture Window action before and after this Set Text action and see what the behavior of the execution there.

 

If you are getting black screen, the issue should be with the RDP session which could be engaged by some other user or application. This can create interruption to the Bot execution especially during the unattended mode.

 

If that is the case, please follow any of the below method to fix the issue.

 

  • Sign-out through RUN (Run → Sign Out)

or

  • Use the enclose .bat file to properly sign-out from the session.
Badge +7

@Padmakumar 

I already check that it’s not black screen. 

How can I solve this issue?

Userlevel 7
Badge +10

 

@Padmakumar

I already check that it’s not black screen. 

How can I solve this issue?

 

Still, follow any of the approach which I have mentioned and let me know.

 

If it doesn’t help, please do the text input through Simulate Keystroke action and see if it is working or not.

 

Also, check what is the setting you have currently in place for runner device session. If it is Enforce this screen resolution for existing device sessions, then kindly change that to Allow devices to override resolution settings.

 

Additionally, you can also do below Registry changes as well.


1. Open Registry Editor in the Bot runner machine.
2. Go to the following registry setting:      "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\MaxIdleTime"
3. Disable the setting: "Computer Policy: Set time limit for active but idle RDS sessions"
4. Run the bot again.

Userlevel 4
Badge +7

@Gift.KP624 have u verified screen resolution in control room for this device in RDP deployment ?  Is screen resolution forced to use  crom control room settings or from VDI enforced.…

In most of the cases screen resolution causes this type of issues (7/10 in my exp).

Badge +7

@rbkadiyam I alreadys change resolution of VM to be the same as my device. The problem is still occued.

Userlevel 4
Badge +8

Hi @Gift.KP624 

Can you add slight delay and try again?

Badge +7

@ChanduMohammad I did it but problem still occures.

Userlevel 4
Badge +8

Hi @Gift.KP624 

You have tried all the possibilities, I'd recommend placing a support case with AA for further assistance. You can find the support section in the bottom of pathfinder landing page

Userlevel 7
Badge +10

 

@Padmakumar

I already check that it’s not black screen. 

How can I solve this issue?

 

Still, follow any of the approach which I have mentioned and let me know.

 

If it doesn’t help, please do the text input through Simulate Keystroke action and see if it is working or not.

 

Also, check what is the setting you have currently in place for runner device session. If it is Enforce this screen resolution for existing device sessions, then kindly change that to Allow devices to override resolution settings.

 

Additionally, you can also do below Registry changes as well.


1. Open Registry Editor in the Bot runner machine.
2. Go to the following registry setting:      "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\MaxIdleTime"
3. Disable the setting: "Computer Policy: Set time limit for active but idle RDS sessions"
4. Run the bot again.

@Gift.KP624 ,

Have you tried this?

Reply