Question

Window in Window problem (Image recognition)

  • 7 November 2022
  • 2 replies
  • 260 views

I have this issue with migrated tasks, but when I copy the line with "Copy to shared clipboard" to a new task the line works well, If I copy to the first line on the migrated task to discart other kind of problems I get the same error. When I've tried to copy again from the new task to the old(migrated) the same error occurs. This issue occurs with Image recognitions, object clonings and if (With image condition). The bot packages version´s are the same.

 

ERROR: "Unable to read the target image file. Use a different image format or a valid image file"

 

I can't access to answer's URL of that post, but I think that is probably the same.

 

https://apeople.automationanywhere.com/s/question/0D52t000017LWg8CAG/error-message-unable-to-read-the-target-image-file-use-a-different-image-format-or-a-valid-image-file/p>


2 replies

Userlevel 7
Badge +13

Hi @Edu.N. ,

 

The issue is with all the Image Recognition commands in some Tasks. However, if you create a new task then the IR commands should work. Follow below steps to fix the issue.

  1. Check the Local File path where the task is getting downloaded on the runner machine.   
    Example: C:\Users\<username>\AppData\Local\AutomationAnywhere\resources\b24a34fe-99b2-415c-9c7f-1bdc16fa5a8c_367265b09a33de80\Automation Anywhere\Bots\....\....\...
  2. If the path is more than 255 characters, then we will get the error due to limitations from the OS side.
  3. Move the task to a shorter path in the Control room and then the issue should be resolved.
Userlevel 3
Badge +6

Dear @Edu.N.,

 

It sounds like you are encountering an error when using certain actions in a migrated task in Automation Anywhere. This error message indicates that the system is unable to read the target image file, which can occur for a variety of reasons.

There are a few things you can try to resolve this issue:

  1. Check the file format and ensure that it is a valid image format (e.g. PNG, JPG, BMP). Automation Anywhere may not support certain image file formats, so using a different format may resolve the issue.

  2. Check the file path and ensure that it is correct and that the image file exists at the specified location. If the file path is incorrect or the file does not exist, this could cause the error.

  3. Check the file permissions and ensure that the Automation Anywhere service has sufficient permissions to access the image file. If the service does not have the necessary permissions, it may not be able to read the file.

  4. Try using a different image file and see if the error persists. This can help to determine whether the issue is with the specific image file or with the action itself.

  5. If the problem persists, try troubleshooting the action itself. This may involve checking the configuration of the action and ensuring that all required input fields are filled in correctly.

I hope these suggestions help to resolve the issue you are experiencing. If you continue to have problems, please provide more information about the specific actions and the steps you are taking to try to resolve the issue. This will help me to better understand the problem and provide more targeted recommendations.

 

Regards,

Reply