Question

Problem to download document attached in email using Action Email Connect

  • 18 January 2023
  • 7 replies
  • 53 views

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Hello everyone.

The idea for this bot is make the connection to the email using the action Email Connect and then download the document attached for the unread email for determinate emails address.

But, I have a error in the line 3.

Can, please help me to find a solution for this problem:

Currently I did the connection to my email. Until the line 2, work fine, the connection is successful



but in the line 3 I received the error with the following message “The provided connection details are invalid”

somebody have idea, what more I need to do or change in my configuration

Thanks.


7 replies

Userlevel 4
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@Fatima 6238 

 

Title

Unable to loop through emails

Summary

**Applicable to A360.x**

Cannot loop through emails and get it to pull the variables - subject, message, etc

Cause

Key Mapping was missing and Email disconnect had to be removed from the loop

Resolution/Workaround

  1. Create custom variables for Email subject and Message ( as per requirement)

image.png
       2.Map these variables to the custom created variables

To Map :

  1. Under Loop action Select mapped variables -> Add variable mapping
  2. Enter the Key Value and map it to the desired variable from the drop down list
  3. Verify the key and mapped variable from table
  4. Add the string variables in Message box to display the results expected Under "enter message to display" choose the variable that has to be displayed

image.png

image.png

Additional Information

Disable/Delete the Email Disconnect from loop or keep it outside the loop

Userlevel 4
Badge +9

@Fatima 6238  seems wrong port 

 

Read Gmail messages on other email clients using POP

You can open your messages from Gmail in other mail clients that support POP, like Microsoft Outlook.

Step 1: Make sure POP is the best way to read your emails

IMAP and POP are both ways to read your Gmail messages in other email clients.

IMAP can be used across multiple devices. Emails are synced in real time.

POP can only be used for a single computer. Emails aren't synced in real time. Instead, they're downloaded and you decide how often you want to download new emails.

Step 2: Set up POP

First, set up POP in Gmail

  1. On your computer, open Gmail.
  2. In the top right, click Settings Settings and then See all settings.
  3. Click the Forwarding and POP/IMAP tab.
  4. In the "POP download" section, select Enable POP for all mail or Enable POP for mail that arrives from now on.
  5. At the bottom of the page, click Save Changes.

Next, make changes on your email client

Go to your client, like Microsoft Outlook, and check these settings.

Incoming Mail (POP) Server

pop.gmail.com

Requires SSL: Yes

Port: 995

Outgoing Mail (SMTP) Server

smtp.gmail.com

Requires SSL: Yes

Requires TLS: Yes (if available)

Requires Authentication: Yes

Port for TLS/STARTTLS: 587

If you use Gmail with your work or school account, check with your administrator for the correct SMTP configuration.

Server timeouts Greater than 1 minute (5 is recommended)
Full Name or Display Name Your name
Account Name, User Name, or Email address Your email address
Password Your Gmail password
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Thanks, I follow your intructions, but the error continue.

I did your steps but not work yet.

Userlevel 4
Badge +9

@Fatima 6238  : so you verified that IMAP access is enabled and also below imap server information and port correct in your configuration ?

 

Step 1: Check that IMAP is turned on

  1. On your computer, open Gmail.
  2. In the top right, click Settings Settings and then See all  settings.
  3. Click the Forwarding and POP/IMAP tab.
  4. In the "IMAP access" section, select Enable IMAP.
  5. Click Save Changes.

Step 2: Change SMTP & other settings in your email client

Use the table below to update your client with the correct information. For help updating your settings, search your email client's Help Center for instructions on setting up IMAP.

Incoming Mail (IMAP) Server

imap.gmail.com

Requires SSL: Yes

Port: 993

Badge +1

@Fatima 6238  Hello, did you manage to solve the problem?

Badge +1

@Fatima 6238  : so you verified that IMAP access is enabled and also below imap server information and port correct in your configuration ?

 

Step 1: Check that IMAP is turned on

  1. On your computer, open Gmail.
  2. In the top right, click Settings Settings and then See all  settings.
  3. Click the Forwarding and POP/IMAP tab.
  4. In the "IMAP access" section, select Enable IMAP.
  5. Click Save Changes.

Step 2: Change SMTP & other settings in your email client

Use the table below to update your client with the correct information. For help updating your settings, search your email client's Help Center for instructions on setting up IMAP.

Incoming Mail (IMAP) Server

imap.gmail.com

Requires SSL: Yes

Port: 993

 

 

Thanks @rbkadiyam, I requested help with this, with the team support. I will let know you if I can fix this problem.

 

 

Badge +1

@Fatima 6238  Hello, did you manage to solve the problem?

Not yet, I am waiting the support from the team support to change the configuration in my mail account.

Thanks for check my problem, I will let you know if I can fix this problem.

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