Solved

Duplicate background processes causing slowdowns

  • 25 September 2023
  • 3 replies
  • 161 views

Badge +1

When working on a bot I have been getting duplicate background processes for multiple Auto Anywhere processes. The duplicate Java Launcher causes horrid lag in excel which I can fix by force stopping down to one instance of the Java Launcher. Any idea what could be causing this? I am fairly new to AA and recently got a new computer and I don’t remember the lag happening before that. My hunch is it is something to do with having multiple devices. Even though it is only actively connected to the local device, that is the only thing I can think of as being different since the issue is now reproducible on the old computer. 

 

icon

Best answer by ravi.pothana 26 September 2023, 21:32

View original

3 replies

Userlevel 3
Badge +8

Hi @jduncan,

Did you try restarting bot agent service? if not could you please restart the bot agent service and see how its works. 

 

Badge +1

How do I restart the bot agent? I uninstalled and reinstalled 10+ times before figuring out it was the background processes and the behavior is the same each time. 

Userlevel 3
Badge +8

I would also try deleting the device registration from the control room before installing the bot agent in the device, here are the steps:

Navigate to manage >> Devices, select your device and delete it from Control room.

Below are the steps for restarting bot agent service :

  • Click on Windows+R
  • Type services.msc
  • Hit Enter
  • Check for “Automation Anywhere Bot Agent Service”
  • Right Click and “Restart”

At the same time please verify the bot status in the “Activity” tab, whether its “in progress” or completed, so it gives you an idea if the bot is still executing. 

 

Reply