Bot failing

  • 21 January 2024
  • 2 replies


I am getting this error after running existing bot- 


None of the user(s) provided have a default device or all sessions on the default device(s) of unattended user(s) have been allocated to user(s) with bot creator, attended, or citizen developer licenses


This bot ran successfully one month ago but now now.

Please help me in resolving this error as I am new developer.


Best answer by ravi.pothana 22 January 2024, 20:43

View original

2 replies

Userlevel 7
Badge +13

Hi @vijtad ,


Try the below steps and let me know.


  1. Stop the Automation Anywhere Bot Agent Service.
  2. Delete file from path: C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere
  3. Start the Automation Anywhere service.
  4. Connect the Bot Agent and run the bot.


  1. Delete the device from Control Room and register it again.
  2. After successful registration, run the bot.
Userlevel 3
Badge +8

Hi @vijtad,

Here are a few things you can check:

Default Device Availability: Ensure that the user(s) have a default device assigned and that the device is available. If all sessions on the default device(s) have been allocated to users with bot creator, attended, or citizen developer licenses, the bot will not be able to run.

Device Pool Settings: If you're using device pools, check the settings and make sure that the bot is assigned to a device pool with available devices.

User License: Check the user's license type. Unattended bots can only run on devices assigned to users with unattended bot runner licenses.

Bot Schedule: If the bot is scheduled to run at a specific time, ensure that a device is available at that time.

Bot Configuration: Check the bot's configuration in the Control Room. Make sure it's set to run on the correct device or device pool.

Software Updates: If the bot was running successfully a month ago but is not running now, check if there have been any software updates or changes in your environment that could be affecting the bot's operation.

Thank you.