Question

AA 11.3.4.0 Chrome issue

  • 17 February 2023
  • 15 replies
  • 265 views

Badge +3

Hi all,

 

During development of a task using Chrome in short periods of time i got a Out of memory popup (or something similar) and after I closed it several times, my bot doesen’t seem to recognise any object in Chrome (current or new, not related to said bot). Furthermore, smart recorder is very slow and innacurate as well as object cloning in Chrome. In IE and other desktop applications object are being recognised normally as usual.

 

Also, I’ve noticed a large increase in CPU load caused by ‪C:\Windows\System32\SearchFilterHost.exe. Other machines do not have this process at all. I don’t know if that is related to the issue but it appeared in the same time.

 

I’ve tried to reinstall Chrome, remove and add plugin, restarted the machine multiple times but no help. Is there any way to fix this, maybe somehow to “reset” AA client?

 

Thanks,


15 replies

Userlevel 1
Badge +4

@mblaskovic.

AA based components are not worth troubleshooting for that as it is related to things related to the necessary Windows Search service. I would do all of the below if I were you for starters, but feel free to test after each below item is performed.

1. Start > Troubleshoot settings >Additional troubleshooters > Search and indexing > Run the troubleshooter > Search or indexing is slow.
2. Start > Indexing Options > Advanced > Rebuild.
3. Open an administrator command prompt > run sfc /scannow and repair all the files.
4. Reboot and retry.

Userlevel 5
Badge +10

@mblaskovic 

 

1. Close Process and Disable Windows Search Service

If Microsoft Windows Search Filter Host is eating a lot of CPU usage when you search something, it's OK, because this indicates that at this moment the indexing service is working intensively on gathering information and rebuilding the search index.

But if Microsoft Windows Search Filter Host high CPU problem occurs without reasons, you can try closing this process and disabling the Windows Search service.

Here is the tutorial on how to close this process:

  • Right-click on the blank area of the taskbar.
  • From the menu, choose Task Manager.
  • Under the Processes tab, find this process, right-click on it, and choose End task.

Here is the tutorial on how to disable Windows Search service:

  • Press "Windows + R" keys to call out Run
  • In the box, type "msc" and then press Enter.
  • In the Services window, scroll down to find Windows search service and then right-click on it.
  • Choose Properties.
  • On the new window, expand Startup type and choose Disabled.
  • Click OK

 

disable Windows Search service
Badge +3

Thank you for your input, indexing has been handled, but it was not related to the problem with Chrome objects not being recognised.

Userlevel 5
Badge +10

@mblaskovic  can you check if this is enabled ?

 

Userlevel 5
Badge +10

@mblaskovic 

 

 check the version of the package. Try using 2.0.10 or 2.0.11 version of the recorder package.

 

(OR)

Resolution/Workaround

Plugin Installation via Chrome Store: 

  1. Open the below URL in the chrome browser.
    1. Version .13 or lower :https://chrome.google.com/webstore/detail/automation-anywhere/jjpdebaihkangkfpbgefmnnlafkahebn
    2. Version .14 or above (Manifest v2): https://chrome.google.com/webstore/detail/automation-anywhere-a2019/kammdlphdfejlopponbapgpbgakimokm
    3. Version .26 or above (Manifest v3): https://chrome.google.com/webstore/detail/automation-360/kammdlphdfejlopponbapgpbgakimokm

Note: Internet connection is required for this step.

  1. Click the Add to Chrome button to add the extensions.
  2. Close and relaunch the browser again. Now use the Recorder command to capture controls on the browser using Automation 360.


Note: Make sure below registry keys are added properly if using Automation 360 v13 or earlier; if not, add them manually and restart the machine.

  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Google\Chrome\NativeMessagingHosts\aa.browser.shim 

  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Google\Chrome\Extensions\jjpdebaihkangkfpbgefmnnlafkahebn

  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Google\Chrome\NativeMessagingHosts\automation.chrome.agent




Note :  Make sure below registry keys are added properly if using Automation 360 v14 or later; if not, add them manually and restart the machine.

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Google\Chrome\Extensions\kammdlphdfejlopponbapgpbgakimokm

The version specified (1.1.0.3) may change with different versions of Automation 360 and you can get the details under Google Chrome --> Manage Extension --> Details of A2019 Chrome extension
extension 1.PNG

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Google\Chrome\NativeMessagingHosts\automation.bot.browseragent
extension 2.PNG

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Google\Chrome\NativeMessagingHosts\aa.browser.shim
extension 3.PNG

 

Additional Information

Now we'll be able to capture the objects on Google Chrome browser using Automation 360.



 

Badge +3

@rbkadiyam  I cannot modify this because I’m working in Enterprise  Client 11.3.4.0.

It was all working until i got out of memory message and after that Chrome was not being able to work with objects that were recognised few days earlier. Nothing in the client or the AA files was changed.

Userlevel 5
Badge +9

@mblaskovic 

Kindly verify if you have any blocking from antivirus. Check in  Event Viewer if you have any error message related with Chrome o AAClient.

 

Regards.

Badge +3

@Raul Jaimes I’ve checked Event Viewer for any messages regarding AA or Chrome and there aren’t any errors or warnings. Also, antivirus is monitored by my company policy.

We have multiple identical bot creators and only on this one there is a problem with Chrome since today.

Userlevel 5
Badge +9

@mblaskovic 

Try the following:

1.- Clear\delete the user's Chrome App data folder at below location.
C:\Users\<user name>\AppData\Local\Google\Chrome

Caution: Take the backup before deleting the above folder.

2. Re- install the Chrome Plugin (from Chrome Web store).

 

https://apeople.automationanywhere.com/s/article/Chrome-Plugin-getting-removed-during-task-bot-run

 

HTH

Regards

Badge +3

@Raul Jaimes Thank you for the suggestion but it still doesen’t work. Object cloning is very slow and innacurate (if it displays an object it has these properties: for example technology Standard, type Pane but when it used to work that object was technology HTML, type TextBox). There aren’t any messages when recording regarding the Chrome plugin missing.

Badge +3

@rbkadiyam thank you for your response, but sadly I can’t see the pictures you posted because I don’t have the privileges or it has been removed from system. Could you share a link to solution maybe?

Userlevel 5
Badge +9

@mblaskovic 

Kindly verify the AAClient version in the other VMs and the Control-Room version you have. 

Regards

 

Badge +3

I have managed to solve my problem but it worked for only one day, today i got the same issue with HTML technology not visible at all and my SAP GUI automation commands do not work anymore - SAP window title is blank all of a sudden.

This was the solution but only temporary: 

 

FIX

  1. Open the Start Menu and search for Command Prompt.
  2. Right-click it and choose to Run as administrator
  3. Type regsvr32.exe oleacc.dll  and hit Enter.

...........................................................................................................................................................

  1. Open File Explorer and type %windir%\SysWoW64 in the address bar. The 32-bit Command Prompt executable is located in this folder.
  2. Right-click on the cmd.exe file and choose to Run as administrator. A 32-bit elevated Command Prompt instance is opened.
  3. Execute the regsvr32.exe oleacc.dll command as explained above. The file is now registered and a confirmation dialog is displayed
  4. Restart the machine once the above step is performed.

 

Any ideas what could i try next? Maybe check out some logs or config files?

Badge +3

Hey @Raul Jaimes , sorry for late reply, I’ve found some AA related logs in Event viewer, after detailed inspection. I can’t figure out what does that point to and how to fix it.

 

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

- <System>

  <Provider Name=".NET Runtime" />

  <EventID Qualifiers="0">1026</EventID>

  <Version>0</Version>

  <Level>2</Level>

  <Task>0</Task>

  <Opcode>0</Opcode>

  <Keywords>0x80000000000000</Keywords>

  <TimeCreated SystemTime="2023-02-21T09:46:09.7885832Z" />

  <EventRecordID>14190</EventRecordID>

  <Correlation />

  <Execution ProcessID="0" ThreadID="0" />

  <Channel>Application</Channel>

  <Computer>XYZ.ad.local</Computer>

  <Security />

  </System>

- <EventData>

  <Data>Application: AAProxyServer.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.ObjectDisposedException at System.Net.Sockets.Socket.EndAccept(System.IAsyncResult) at Automation.ProxyServer.PolicyServer.OnConnection(System.IAsyncResult) at System.Net.LazyAsyncResult.Complete(IntPtr) at System.Net.ContextAwareResult.CompleteCallback(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Net.ContextAwareResult.Complete(IntPtr) at System.Net.LazyAsyncResult.ProtectedInvokeCallback(System.Object, IntPtr) at System.Net.Sockets.Socket.CompleteAcceptResults(System.Object) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()</Data>

  </EventData>

  </Event>


Application: AAProxyServer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ObjectDisposedException
   at System.Net.Sockets.Socket.EndAccept(System.IAsyncResult)
   at Automation.ProxyServer.PolicyServer.OnConnection(System.IAsyncResult)
   at System.Net.LazyAsyncResult.Complete(IntPtr)
   at System.Net.ContextAwareResult.CompleteCallback(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Net.ContextAwareResult.Complete(IntPtr)
   at System.Net.LazyAsyncResult.ProtectedInvokeCallback(System.Object, IntPtr)
   at System.Net.Sockets.Socket.CompleteAcceptResults(System.Object)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

Userlevel 5
Badge +9

@mblaskovic 

Try reinstalling .Net Framework  and test again.  Also you can run the Diagnostic Tool and verify if you see  more error messages.

 

 

Regards

Reply