Question

My Local Device is not getting connected to the control room, even after deleting the device and adding it again didnt solve the problem. After trying out the connect device I'm still getting the same error. Can anyone help me fix this problem?

  • 13 August 2021
  • 11 replies
  • 1766 views

I have tried the manage>Devices>connect local device, but it still shows connect to local device.


11 replies

Userlevel 6
Badge +15

Hi @Vishnu G Ashok​ ,

 

AA 2019 Community Edition - Device Disconnect Problem Resolution

 

I have found out the solution to this problem. Kindly go to the following folder:

C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere\

 

Check if you are able to view the file: registration.properties.

If not present then it means the file is either corrupted or deleted and hence shows Device Status Not Connected.

 

Please follow the simple steps:

1.      Remove the Device from your AA Control Room WebURL (Go to Device > My Devices under the url: https://community.cloud.automationanywhere.digital/#/login)

2.      Uninstall AA Bot Agent from Windows Control Panel

3.      Restart your windows operating system

4.      Go to the Control Panel and see if the AA Bot Agent is completely uninstalled

5.      Go to Services and check if the AA Bot Agent Service is completely removed

6.      Go to the folder: C:\Windows\System32\config\systemprofile\AppData\Local\

7.      Check if you are able to see: AutomationAnywhere folder.

8.      If present then rename it to: AutomationAnywhere_Old

9.      Once 4, 5, and 8, are confirmed then download the new AA Bot Agent

10.   Install the new AA Bot Agent and check in the Control Panel that it should be available.

11.   Go to the Services. The Agent should be up and running.

12.   Go to the folder: C:\Windows\System32\config\systemprofile\AppData\Local\

13.   You should see the new folder: AutomationAnywhere\

14.   Login to your AA 2019 Community Edition Control Room WebURL.

15.   Go to Device > My Devices.

16.   Now Add the Device. Here, by default, it will find that the AA Bot Agent is installed.

17.   Then add the AA Extension to your browser.

18.   Then connect to your system.

19.   Your Device will be connected.

20.   Now go to the folder: C:\Windows\System32\config\systemprofile\AppData\Local\AutomationAnywhere\

21.   You should see: registration.properties file.

22.   For safety, please take a backup of all the files: registration.properties, publicKey.pem, privateKey.pem, and AA-DB.mv.

23.   Please note that only AA-DB.mv will keep on changing whenever you login to your control room while rest of the files is generated the first time. So keep these handy.

Userlevel 6
Badge +15

Might be below the steps to help you,

 

  • Delete the username in the control room
  • Please uninstall the bot agent and delete the installation folder from the location
  • Restart the machine," after the restart of the machine check the existing installation location still any files there or not. If you find any files please remove all of them.
  • Start with the fresh installation again

 

Thank you Arasu, but i have the registration.properties file in the specified folder. still showing the error. Is there any other solution?

Thank you Arasu. I will try that. but all of the bots that i have created until now cannot be accessed right. I have to start fresh after that. right?

Userlevel 6
Badge +15

The bots are stored in the CR locations.

Can you please confirm which version are you using? AA11 or A360 Community or A360 Enterprise.

 

Thanks!

Userlevel 6
Badge +10

Hi @Vishnu G Ashok​,

 

Please refer to the below article:

https://apeople.automationanywhere.com/s/article/unable-to-connect-device-to-control-room

 

Hope this helps.

 

Thanks,

Vijay

Userlevel 3
Badge +6

Dear @Ashok 1159 

 

We have different scenario when we cant connect to device are following:

  1. Reinstall the bot agent with latest version
  2. Restart the bot agent services
  3. Make sure AA certificate for control room is added in your local machine 
  4. Restart the machine 

Regards,

Badge

Facing the same issue.. device not at all getting connected

 

Userlevel 5
Badge +14

@vijayjarvis92  remove automation anywhere folder  under

C:\Windows\System32\config\systemprofile\AppData\Local

 

restart your machine, login control room and click on connect 

Badge

i tried to install the bot for 5 times yet its showing disconnected in my control room

plss help

Userlevel 6
Badge +15

Hi @dipshikha,

Please reach out the AA support team for the above issue. 

 

Reply