Question

Why does scheduled bot give an error even though it runs perfectly when i run it from controlroom?

  • 27 March 2023
  • 8 replies
  • 195 views

Userlevel 3
Badge +10

I scheduled a bot on controlroom. When it runs itself, gives error. But when i run it over controlroom, it runs without an error.

Controlroom screen resolution 1920*1080, when its scheduled, i thought it runs how the settings is in controlroom, because i marked it like that 

 

here are the settings on controlroom and botrunner device

 

when i run a task over controlroom, the resolution on botrunner is 1920*1080, (i thought it should be like that too when its scheduled and runs automatically)

when i run a task over botrunner while i watch it, screen resolution is different(but the scheduled task should work as in the settings on the control room as i know)


8 replies

Badge +4

Hi,

We need to do few settings in the bot runner device. Refer the below link

https://docs.automationanywhere.com/bundle/enterprise-v11.3/page/enterprise/topics/control-room/bots/my-bots/rdp-based-approach-to-bot-deployment.html

 

Thanks,

Diksha

Userlevel 5
Badge +14

@Semih 3318 ::

here is the summary of this issue::

when you run bot in watch mode or attended mode, the local system where you logged in (laptop) take precedence over control room and desktop resolution and scaling percentage will take from your laptop.

where as you trigger schedule the values that are set in control room will take consideration.. hence you are getting error.

 

Userlevel 3
Badge +10

@rbkadiyam Hello,

But it works perfect when i run the task from controlroom(unattended mode) or if i watch the task running on botrunner(attended mode) it works.

But when it runs automatically from controlroom(as its scheduled) it doesnt work

Userlevel 3
Badge +10

Hi @Diksha.M1 

well i dont think this is the solution.

there is no problem to connect to botrunner, it connects and runs perfect when i run the task from controlroom, or when i run it from botrunner.

but it gives error when it runs automatically from controlroom(scheduled)

it gives error at same place everywhere (Unable to find the image. Make sure image is present on the screen and try again.)

but when i run it from controlroom it works…

thats weird, i guess i need to capture some places again

Userlevel 5
Badge +14

@Semih 3318  are you running the same machine / bot runner that you are using for unattended or watch mode  vs schedules ?

Userlevel 3
Badge +10

@rbkadiyam yes same machine. When i run it myself from controlroom, or when i watch the botrunning it works.

but when it works automatically as its at scheduled time, it starts working but gives error, on recorder or mouse click etc.

its weird, cause when i run it from controlroom it works

Badge +1

@Semih 3318  I am having the same exact problem.

Robot runs fine, In attended mode and in unattended mode if I run it from control room.

But, it fails at same location if it runs by itself on a schedule.

Did you find a solution for this weird behavior?

 

 

Userlevel 3
Badge +10

@mohamed.badran unfortunately, i could not find a solution for that. But it was a task which runs over Citrix app. As I searched citrix has a different things to install such as citrix receiver and citrix remote bot agent.

I am just guessing your task may need an installation like this, or have you checked the packages if they are latest version ? also screen resoultion settings might be the place you need to look up

Reply