Question

Unable to find TEXTBOX. 'Search Criteria' does not match error

  • 28 January 2023
  • 9 replies
  • 664 views

Badge +4

Hi,

I was trying to capture a textbox in a web application in a loop and I am getting this error every time I try to do so. Please help me with this.


9 replies

Userlevel 5
Badge +12

Hi @ajith 2492 

Checkout below screenshot to change different technology using capture command. Can you try changing to “Capture object with Microsoft UI Automation (COM)” and give a try?

 

Also checkout below documentation to know more,

https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/aae-client/bot-creator/commands/capture-using-specific-technology.html

 

Badge +4

Just tried that method but ‘set text’ action is missing from the ‘action to take on object’ menu 

Userlevel 5
Badge +12

Just tried that method but ‘set text’ action is missing from the ‘action to take on object’ menu 

Can you share the screenshot? @ajith 2492 

Userlevel 5
Badge +12

Just tried that method but ‘set text’ action is missing from the ‘action to take on object’ menu 

Can you share the screenshot? @ajith 2492 

Hi @ajith 2492 

It is available, Can you try capturing the object again

 

Badge +4

my text box is being captured as a combo box. I think that’s why set text action is not shown

Userlevel 5
Badge +12

my text box is being captured as a combo box. I think that’s why set text action is not shown

Probably, can you try with other Capture Object technologies

Userlevel 7
Badge +13

Hi @ajith 2492 ,

 

If the above suggested approach doesn’t help, please try after changing the Recorder package version.

Badge +4

Hi @Padmakumar 

Tried changing recorder package version but still same error is showing. Is there any other reason this error is showing?

Userlevel 7
Badge +13

Hi @Padmakumar 

Tried changing recorder package version but still same error is showing. Is there any other reason this error is showing?

Normally, the suggested approaches should fix the issue. So, in your case, I would recommend raising a support ticket with AA here for better understanding and fixing the same.

Reply