Question

Unable to Find Link. Search criteria did not match


Badge +2

Hello,

 

I am not sure what else to try. I am getting the “Unable to find Link. Search criteria did not match” error when trying to save the HTML InnerText to variable. I’m able to use the recorder to capture the element but if the web page is refreshed or the bot navigates to that web page again, the bot is not able to find the element on the web page!

 

I’ve tried different combinations of the Object Properties, all fail. I’ve even tried removing all of the Object Properties but the Path. I know some of the elements have parameters that change every time the page is loaded. Even with the object properties unchecked that contain those elements, the bot still can’t find the captured object.

 

I’m not sure what I am missing.


3 replies

Userlevel 5
Badge +14

@bmhelton capture with COM option

Userlevel 1
Badge +3

Have you used wildcard in the Title of the webpage to make it generic?

Are you opening the page in new window instead of new tab?

Badge +2

Sorry for the delayed response! I’ve tried both suggestion and still getting the same result. Unfortunately the project I was working has been closed so I can’t continue to test. Thank you for your replies!

Reply