Question

Unable to add dynamic row to Interactive Form

  • 17 October 2022
  • 3 replies
  • 1 view

I have a very simple bot in which I have a form. The form only has a Dynamic Area and a submit button on it. In the bot, I am attempting to use the Interactive Forms>>Dynamic Area>>Add Row to Dynamic Area action, but no matter what I add in (textbox, checkbox, etc.) I get a generic "Unable to add element to the Dynamic Element0" error.

 

I am using Community, but have run into the same issue in my Enterprise version. Both on .26, and the Add Row action I have tried both Append and Overwrite. Just curious if anyone has been able to get this to work.


3 replies

Userlevel 3
Badge +7

Hi @Jeremiah Logan​ ,

 

Have you tried the Table Element and tried adding rows to it?

 

Kind Regards,

Ashwin A.K

@Ashwin A.K​ I guess I am not understanding what you're asking. You add a Dynamic Area to the form, and then in the Bot you should be able to use the Interactive forms>>Add row in Dynamic area Action to add different elements. You cannot add a table element on top of the Dynamic Area on the form, dropping one overwrites the other. Please explain if I am misunderstanding you.

Badge +5

I was able to figure this out, you must first instantiate and display the form, THEN add rows. I guess I was thinking there was some sort of pre-processing that would allow us to add the fields first.

Reply