Question

Triggers not working for Unattended bot runner license in server?

  • 22 December 2022
  • 9 replies
  • 103 views

Badge +3

When i try to trigger bot in server with unattended botrunner license it is not happening, I created event trigger and assign role based to botrunner .And trigger not working.


9 replies

Userlevel 7
Badge +12

Hi @Venkat 4613 ,

 

Is this your first attempt or was it working before?

You may try to Stop (wait for at least 15 to 30 seconds) and Start the Automation Anywhere Bot agent service in the runner machine. Side by side you may access the control room through the runner account. You should see the below confirmation message on Control Room upon Starting the service again.

 

Test the same after that.

Refer here for further details on Event Triggers

Badge +3

Hi  @Padmakumar 

It was my first attempt  and tried the start and stop of bot agent but no use can u pls help me do i need config device or runner license.

 

Userlevel 7
Badge +12

Hi  @Padmakumar 

It was my first attempt  and tried the start and stop of bot agent but no use can u pls help me do i need config device or runner license.

 

 

I hope that you are having a separate machine as the Runner device. Access the control room from the runner machine and go to the Audit log. Then, kindly do the steps as I mentioned in my first comment in the Runner device and see whether you are getting the confirmation message on the control room end.

 

Test the trigger after that.

Badge +3

@Padmakumar  I did the start and stop of service but  i am not able to see pop up

Userlevel 7
Badge +12

@Padmakumar  I did the start and stop of service but  i am not able to see pop up

 

Could you please share below details?

  • Control Room & BOT Agent versions
  • Number of Runner devices
  • Auto login is enabled for BOT execution or not
Badge +2

@Venkat 4613 

 

please check the services in this and please check if they are active

https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/aae-client/attended-automation/cloud-event-triggers.html

 

cheers

 

Badge +3

@Padmakumar  pls find below details

 

version 21.222

two runner devices

yes auto login enabled

Userlevel 7
Badge +12

Hi Venkat,

 

Kindly refer here for further details on Event Triggers. Please check whether you have missed anything while creating the trigger.

 

If still encountering the issue, kindly raise a support ticket here.

Userlevel 4
Badge +8

hi @Venkat 4613 

Please, first check the below reference:

https://docs.automationanywhere.com/bundle/enterprise-v2019/page/enterprise-cloud/topics/aae-client/attended-automation/cloud-event-triggers.html

If it still doesnt work, check the following article:

https://apeople.automationanywhere.com/s/article/A360-x-trigger-on-Bot-Runner-device

 

  1. Only "Bot Runner" users can create and activate the trigger from a particular bot runner machine where the trigger is about to run.
  2. It is not possible to create and activate trigger using the AAE_Admin role or Admin user
  3. Non-Bot runner can create or manage the trigger but it will never get activated.
  4. Once the trigger is created with the help of Bot Runner users in the Bot Runner device, the "Web Browser" must be refreshed manually to "activate" the trigger.
  5. To run the trigger in "unattended" mode, please use the Lock and disconnect approach.
  6. Logoff/Signout is not supported
  7. Need to re-enable trigger [by login into the bot runner machine, opening CR using Bot runner credentials, and refreshing the web browser. you should be able to see a message that says "trigger activated"]. this is only applicable when Bot Agent service/Bot Runner Device restart.

 

HTH

Regards

Reply