Question

Stuck in "Run bot with queue" state, queue not visible

  • 20 February 2023
  • 2 replies
  • 437 views

Badge +1

Hi, I am using Automation 360 build 16685 (on-prem) I am trying to run a bot with a queue but the queue is not listed to select it, the bot is already configured with the work item template, tried all users and assigning various roles, but I don't know what is left to do. Queue status is "not in use"


2 replies

Userlevel 5
Badge +10

@RAFAEL AUGUSTO.N 

 

Issue happens when any of the pre-requisites are not met to run the bot with queue. Below 2 are the most common reasons when we observe this issue:

  1. User running the bot with queue doesn't have queue consumer role assigned.
  2. WorkItem template linked in the bot and in the queue are not identical.

Resolution/Workaround

To resolve this issue, 

  1.  Assign queue consumer role to the user who is running the queue from CR Administration > Users > Edit.
  2.  Make sure same WorkItem template is selected inside bot and in the queue are exactly same in terms of WorkItem structure and WorkItem name.
Badge +1

It already worked for me, the solution was to create a role with access to the "workload" and then add it to the "Consumers" section of the queue. Then, when trying to execute the bot with the tail, it already appeared to select it.

 

 

Reply