Solved

Old indices error while updating control room from V27

  • 18 June 2024
  • 3 replies
  • 73 views

Userlevel 1
Badge +7

Hi everyone,

I have updated a control room that was on v24R2 to v27 without errors.

For context, the control room, database and elasticsearch are installed on the same windows VM.

I now want to update it from v27 to v30 but I get an error “Installer has detected that there are ElasticSearch indices that are old and cannot be migrated automatically. Setup will abort”.

 

I want to follow what has been explained here

However, I fail connecting to elasticsearch while it was possible beforehand -I have tried ports 47599, 47600, 9200, 9300)

When I go to the services, the Elastic Search service is shown active. It keeps on failing even I restart process.

On the other hand, the main website can still be reached and bots be run.

 

How can I solve this problem ?

icon

Best answer by Augustin 9 July 2024, 11:46

View original

3 replies

Badge +1

@Augustin 

Please let me know if this helps..

Userlevel 1
Badge +7

@Augustin

Please let me know if this helps..

Hi Goodgist and thanks for your answer.

Those GET/POST/DELETE requests is exactly what I want to do.

Unfortunately I do not have a working url:port to send those requests.

I have tried with postman and google chrome and do not get results when requesting localhost:45799 (or other posts)

Userlevel 1
Badge +7

This was solved by the automation anywhere support. I had to reset the elasticsearch username and password. Then I was able to go through the migation of ES.

Reply