Question

Mouse click failing on java application

  • 11 October 2022
  • 2 replies
  • 25 views

Hey all, I have a process where I use a mouse click to press a button in a JAVA based application on Internet Explorer.

 

I have 2 bot accounts working on the same server.

 

One bot account can click the button, the other one failes to click the button.

 

I checked all the java settings for bot bot accounts and everythin is the same. Also screen resolution is the same.

 

Any idea what can cause this error?


2 replies

Userlevel 2
Badge +6

@Marcia van Nes​ When I've had issues in the past interacting with JAVA applications, it has usually been an issue with the Java access bridge not being installed or enabled correctly.

 

There are a few older KB articles for this, assume they are still fine to check:

 

https://apeople.automationanywhere.com/s/article/A2019-Recorder-command-fails-to-capture-on-Java-based-application-hosted-on-Jre-7/p>

 

https://apeople.automationanywhere.com/s/article/Enable-Java-Access-Bridge-for-Java-Plugin/p>

Thanx for the help! We solved the issue by copying the user image from the account that was working to the one that was not. I have checked the java bridge, it is enabled now. Perhaps that was what was solved the issue, unfortunately I cannot check that now anymore.

Reply