Question

Keystrokes not working when RDP window is minimized or disconnected

  • 14 September 2022
  • 11 replies
  • 26 views

Badge +5

My bot is running fine and getting completed when RDP server is open. However it is unable to insert keystrokes when server is minimized or locked or disconnected. Has anyone faced this issue/ has solution for this?

Any help on this will be appreciated. Thanks!!

 

PS : I have already tried creating D-word through regedit settings (article 000001522) and checked power, local security policy and group editor policy (article 000001473).


11 replies

Badge +5

Hi @Tamil Arasu​ ,

 

This article 000001522 I have already tried (mentioned same in details also) and still facing the same issue.

Userlevel 3
Badge +7

Hi @Rohit Gaurav​ ,

 

Please checkout the below KB

https://apeople.automationanywhere.com/s/article/Insert-Keystrokes-Keystrokes-not-working-when-RDP-window-is-minimized

 

Hope this helps.

Hi @Rohit Gaurav​ ,

 

We have to ensure RDP server is not getting locked during bot run for this issue,

 

Could you provide more details about the issue, and one more thing to note is your bot is allowed to perform as one extra step at every interval of 3 to 4 minutes so that the VM doesn't gets locked??

 

Hi @Rohit Gaurav​ ,

 

We can try to check if the action of inserting keystrokes is completed or not in this scenario inside a LOOP for the required window, putting the keystrokes command inside an IF condition.

 

Pseudo for commands:-

 

LOOP(if the Required_Window_Still exists ):

IF keystrokes field!= NULL :

exit LOOP

ELSE :

continue

 

Let me know if this approach works or not!

Badge +5

Hi @Deepak Kumar Jha​ ,

 

RDP server is not getting locked during the bot run. Bot runs for less than a minute.

 

More details about the issue:

Bot is running fine and getting completed when runner RDP server is open. However it is unable to insert keystrokes when runner server is minimized or locked or disconnected.

Bot does not throw any error on this line, it just completes the action (however nothing gets written where it is supposed to insert keystrokes).

 

Hope this helps!

Badge +5

Hi @Deepak Kumar Jha​ ,

 

Inserting Keystrokes action gets completed, I am attaching 2 screenshots here for a test bot. In correct run, it open webpage types username then opens Notepad and types text into that and towards end message box comes up. In issue run, it does follow same steps (opening webpage, Notepad and message box) but it does not types into username filed and in Notepad beacuse runner machine was minimized. I think this will give you clear picture of the issue.

Hi @Rohit Gaurav​ ,

 

Thanks for sharing the complete query!

 

For the browser it is obvious that it will not enter as the Object cloning/Capturing their will not work if VM(runner server )is minimized or locked or disconnected.

 

But Notepad it should write the data, I am using this in my use cases.

 

->For the Notepad Are you using Coordinates in capturing/ object cloning with SetText as Action?

 

 

Badge +5

Hi @Deepak Kumar Jha​ ,

 

For Notepad I am using capture option and set text action.

Also for browser also I think it should work as bot runner has unattended license, it will complete the necessary actions. Let me know your thought on this.

Hi @Rohit Gaurav​ ,

 

The processes are not allowed to perform the keystrokes or object cloning if the VM is locked.

We are also working on Automation Anywhere V11 projects with bot Unattended license, but we have any key press during idle time to avoid locking, as VM would be locked when machine is in idle mode.

 

I think you should use pseudo logic to avoid the Locking of VM, then it would work fine.

 

 

Let me know any other solution if you get for this Query. I'll be happy to listen!

Userlevel 4
Badge +8

Please check and ensure the scaling settings for remote machine are set to 100% from display resolution settings

yes right!

 

Reply