Question

Keystrokes are not working in unattended mode

  • 9 December 2022
  • 7 replies
  • 102 views

Userlevel 3
Badge +6

Hey!

@micahsmith112 @Tamil Arasu10  I'd like to know why various commands, such as keystrokes and screenshots, do not work in unattended mode.

Is it possible to run these commands in an unattended mode, or is it officially not working?

 

Thanks in advance.

Regards,

Muhammad Shahzaib


7 replies

Userlevel 3
Badge +6

Is it possible to run these commands such as Keystrokes or object cloning etc. in an unattended mode, or is it officially not working?

Userlevel 3
Badge +7

Hi @Zaibi ,

Firstly, welcome to the Pathfinder Community!


Regarding your query, keystrokes work regardless of the nature of deployment, but you have to understand that they only work on the element it is supposed to, if that element is put into focus.

You could try using Window: Activate Action to bring the window to the foreground, but ideally you ought to use Object Cloning/Capture Action as it its much more reliable than keystrokes.
Is anything preventing you from using the former? If so please elaborate so that we can help you out.

Regarding screenshots, then only error I that comes to mind is when the File directory provided doesn’t exist on the server you are running it in.
You might want to look at whether you are including the absolute path i.e., directory path which contains the username.

There are way to overcome that as well, such as creating a Global Variable that you can set for each user.

Kind Regards,
Ashwin A.K

Userlevel 3
Badge +6

Dear @Ashwin A.K,

Thank you very much for your response. I'm actually utilizing keystrokes on the login page because some applications do not support Capture Action: Set Text. Also, I'm saving files from the browser using the Save As Popup, thus it's not working in unattended mode.

I'll look into the queries you sent me.

 

Regards,

Muhammad Shahzaib

Badge +2

Hi @Zaibi ,

I am also facing the same issue - the keystrokes are not working in unattended mode. It is not possible for me to use Object Cloning as it is not recognizing individual objects in application window.  Object Cloning only recognizes the entire window.

Is there any other solution that have worked for you?

Userlevel 4
Badge +7

Hi @Zaibi 

 

Try:

Navigate to CR - > Manage - > Device - > Depoyment ;

Change the device type from "Regular" to "RDP".

HTH

Regards

 

 

Userlevel 3
Badge +6

Hi @Zaibi ,

I am also facing the same issue - the keystrokes are not working in unattended mode. It is not possible for me to use Object Cloning as it is not recognizing individual objects in application window.  Object Cloning only recognizes the entire window.

Is there any other solution that have worked for you?

 

Dear @Anoushka 5074,

 

Not now. I didn't found any proper solution.

Userlevel 7
Badge +11

Hi @Zaibi ,

 

Add Capture → Window action just before and after the error prone area and see whether you are getting a black screen there or not. If yes, it is because that, the last RDP session logout was not proper or someone else might be having an active session while the Bot was executing. Please follow either of the below mentioned step to fix the issue.

  • Logout through the Run prompt (Run→ Log-out)

or

  • Use the enclosed .bat file to properly log-out from the runner machine.

Note: There should not be any other active session on the runner machine during the Unattended Bot execution.

Reply