Question

I am trying to copy a file and in the copied file I have to search some string and replace that. Replace option is in ms word package and the file is .doc as well, but still I fail to replace text as I get the below as error

  • 27 April 2022
  • 7 replies
  • 328 views

Badge +4

An unexpected error occurred.

The supplied data appears to be in the OLE2 Format. You are calling the part of POI that deals with OOXML (Office Open XML) Documents. You need to call a different part of POI to process this data (eg HSSF instead of XSSF)

Please contact system administrator.


7 replies

Same Issue with ME anyone who had solved this problem

Badge +4

Change the format to .docx.. you are allowed to do that​

Thanks for replying @Enab Rasool Dar Basmati​ 

Badge +1

Mine is a .docx but I am still getting this error.  This bot used to work about a year go.  Any other ideas?

Badge +1

I figured it out.  It was a word doc that was wrapped with MS AIP. 

Badge

Can anyone give answer for this error?

Badge

opened the original document.doc file and saved as .docx worked for me. after changing the format manually i was able to use replace text in MS word action.

Reply