Generic Exception error in Excel Go to cell command


I recently migrated from AAEv11 to A360 Cloud.

The migration was more successful than expected, but there are problems that are difficult to solve with Excel Command.


Generic Exception Error is occurring intermittently when using Excel commands on A360.

The error mainly occurs in the 'Excel advanced: Go to cell' command.


There is often a 'Screen: Capture Desktop' command before the 'Go to cell' command, but I'm not sure if this is the cause of the problem.


I suspected that the cause of the problem was that Excel was not ready before executing the command, so I tried using a long value of the Delay command, but the problem was not solved.

As another attempt, I suspect this is because the Excel session management is different from v11, so I tried changing all 'Session Name' to 'Session Variable', but the same problem occurs.


Does anyone have a similar problem to me? If yes, how did you solve it?



11 replies

Userlevel 4
Badge +7

Hi @Sangryeol Lee​ ,


The Line Number where the error occurs is at 120 right?

Could you show us the Action at Line 120?


Kind Regards,

Ashwin A.K

Userlevel 7
Badge +10

Hi @Sangryeol Lee​ 


If there is only one session throughout all excel operations, please try renaming all sessions to Local session > Default

Hello, Action Line 120 is the 'Taskbot: Run' command. It is displayed like this because the error occurs inside the subtask, and the command that actually causes the error is Action Line 44.

Hello, Since this task is a task that collects different Excel files into one Excel file, multiple Excel Sessions are created at the same time. Each Session uses a different Session Name or Session Variable. What should be done in this case?

Badge +1

Good morning, I just launched the BOT in A360 and it gives me the same error in osaciones when doing GO TO CELL to a specific cell, it really catches my attention because the error always originates in the same line and in the BOT there is varies lines where the GO TO CELL command is executed, this catches my attention because the error reported by the control room is:

Error message: !generic.exception!

Line with error: 316


You have been able to gather more information about this error since it is impacting the operation of the business.

Hi Saran,


I have the same issue. I got a generic.exception error on go to cell command in A360. I have multiple excel opened with different session names. This behavioir was not in the V11. How should we treat this? opening just one session is not an option either for me.

I am also having this issue. We just recently migrated over to A360 and I switched my window and session variables over to the A360 format from the string format in V11. It is intermittent and I have not been able to solve it despite many attempts.


I did notice on one of my attempts (I had 2 sessions open when this bot failed). Intermittently, it actually marked the cell in the wrong excel session. This is what prompted me to change it to the correct excel session variables instead of the string variables that were pulled in using "local." Instead of fixing the issue the error message changed to !Generic Exception on my go to cell command. I put this in thinking that would help activate the correct cell.


At this point I am going to update all window and session variables, current and old to A360 variables. Maybe that will help, but I am not so sure after reviewing this thread.


AA let us know if there is anything for this because it is a pain.

Badge +1
We also had the same problem when we migrated from V11 to A360 Cloud, sometimes when the GO TO CELL command was executed, the result was "GENERIC EXCEPTION!", we proceeded to escalate the case to AA and they sent us the updated EXCEL ADVANCED package with version 6.8.0-20220409-020138. I hope my comment will help you.

Userlevel 7
Badge +10

Hi @Sangryeol Lee​ ,


We have fixed "Excel Advanced Errors - Generic Exception" in version A360.25 version of the product (


Customers using CR of .22 version are advised to use this package : bot-command-msexcel-6.2.1-20220331-120805.jar


Customers using CR of .23 and higher version are advised to use this package : bot-command-msexcel-6.8.0-20220409-020138.jar


Root Cause for this error :


What Caused This:

There were 2 issues that caused this problem, major problem was, that we were not able to create a unique session name.

  1. When a bot uses multiple excel sessions in a loop with a session variable the system was not able generate unique session name every time. In case of session variable system generates the session name internally. Random number generator function us used to generate the unique session name, but this was not sufficient when multiple session were used simultaneously. Because a random function may return same number with multiple execution.
  2. There was another problem with the network file, or a file with add-ins. In those types of files if someone performs some external operation then excel was rejecting calls to perform any action as it was busy performing the task requested by the external operation.
  3. There was a back-end input validation problem in case of passing empty value using variable to goto cell.
Badge +3

Hello @irfan.khan (Automation Anywhere Inc)​ ,


Can you please provide another link to download those packages?



Badge +3

Hello @Irfan Khan​ ,


Can you please provide another link to download those packages?